Problem with asian fonts in PDF

0

Dear all,

I'm running Jaspersoft iReport Designer 4.1.1 , and I added 3 new fonts (Japanese, Chinese and Corean).
I have one report showing text in English, and the translation in the relative language on the same page.

My problem is that I'm not able to extract it in pdf : when I launch it from the webinterface, the report is correctly displaying, but when I do "Export / PDF Format", the Asian text is disappearing.

Important : Note that I don't have any issue if I extract the same report in .docx (and the font is correct in the .docx).

Can you kindly help ?

I remain available if you have any questions.

Thanks

nicolas.barillaro's picture
Joined: Dec 28 2016 - 3:02am
Last seen: 2 months 15 hours ago

2 Answers:

0

You'll need to setup font extensions. Sorry but not sure if it's supported in iReport Designer 4.11. If it isn't, you'll just have to switch over to Jaspersoft Studio.

https://community.jaspersoft.com/wiki/custom-font-font-extension

hozawa's picture
64906
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 year 3 months ago
0

Dear Hozawa,

Thanks a lot for your answer.
Anyway this had already been done way before, but it still doesn't work.
We already add a new font using this technique (a latin font), and we didn't encounter any problem. We re-did it few times to be sure we correctly setup extensions, but still doesn't work.

Do you have any explanation ?

Thanks a lot.

nicolas.barillaro's picture
Joined: Dec 28 2016 - 3:02am
Last seen: 2 months 15 hours ago
Feedback