Jump to content
JasperReports 7.0 is now available ×
  • Getting Started with Jaspersoft Studio


    morlandin
    • Edited on:
    • Version: v8.2, v8.1, v8 Product: Jaspersoft® Studio

    Overview

    In this tutorial we will see what are the requirements to use Jaspersoft Studio.

    Requirements to Run Jaspersoft Studio

    Jaspersoft Studio needs a 64bit or 32bit processor and at least 500MB of Hard Disk space. The amount of the RAM is really dependent from the complexity of the reports, a value of 1GB dedicated to Jaspersoft Studio is recommended, since in your system there are many other things that require RAM it's suggested a total value of 2GB.

    Software Requirements and Installation

    As any other Java project Jaspersoft Studio require the Java Runtime Environment (JRE), but to compile the report scriptlets a full distribution of Java is required. You need to download the Java Development Kit (JDK), supported versions of Java could be found in our Platform Support Guide, please check this guide for specific version details.

    At the moment Jaspersoft Studio support the most common Operating systems, such as:

    • Windows 10 and above with 64 bit;
    • Linux with 64 bit; Debian Linux 8, 9, 10; Cent OS 6.x, 7.x
    • MacOS 11.x, 12.x at 64 bit.

    The download of  Jaspersoft Studio starts from HERE (community editions), a page with listed all the release of Jaspersoft Studio will appear, click the one on the top of the list (the last version) and a grid with many links will be shown. 

    • The Eclipse RCP package is available in the following formats for community and commercial versions.

      Commercial Versions:

      • TIB_js-jss_x.x.x_linux_x86_64.tgz

      • TIB_js-jss_x.x.x_macosx_x86_64.dmg

      • TIB_js-jss_x.x.x_sources.zip

      • TIB_js-jss_x.x.x_windows_x86_64.exe

      • TIB_js-jss_x.x.x_windows_x86_64.zip

      x.x.x represents the version number of Jaspersoft Studio.

       

      For community only, unsupported versions for the Eclipse RCP are available as a convenience for users who are

      in a restricted environment and can't download or install an .exe. file:

      • TIB_js-studiocomm_x.x.x_linux_amd64.deb

      • TIB_js-studiocomm_x.x.x_linux_x86_64.tgz

      • TIB_js-studiocomm_x.x.x_macosx_x86_64.dmg

      • TIB_js-studiocomm_x.x.x_windows_x86_64.exe

      • TIB_js-studiocomm_x.x.x_windows_x86_64.zip

       

      The community version is also available as an unsupported Eclipse plug-in, called the Jaspersoft Studio plugin.

      You can install it from the Eclipse Marketplace or download using the Eclipse Update Manager. See the

      following article on the community website for more information about working with the Jaspersoft Studio

      plugin.

      Contributing to Jaspersoft® Studio and building from sources

    Be sure to download and install the correct version of Java and Jaspersoft Studio for your Operating system. In most of cases the installation 
    requires only the download of the correct file and then double-clicking on in, this will show the installation wizard and here you can follow the on screen instructions.

     

    Check the architecture of the Operating System

    If you are unsure on "how many" are the bits of your system follow this steps:

    • Windows

    Go in the Control Panel, then click on System & Security and then on System, then in the presented Window check System Type.

    It will have information such as this: 64-bit operating system, x64-based processor.

    • Linux

    Open the terminal and type uname -a , then you will see a response like this:

    2(5).png.1194e9196d58fa501329ca199022ad3a.png

    x86_64 means a 64bit Operating System.

    • MacOS 

    Open the terminal, if you don't know how to do it open the Launchpad,  type "Terminal" in the search bar and select the first result. Once the terminal is opend type uname -a , and press enter. A message like this will appear: 

    3(2).png.92d33997eeec58de2bb45f689be4be35.png

    x86_64 means a 64bit Operating System. At this time the 64 bit version it is the only provided for MacOS.


    Accessing the Source Code

    The last version of the source code is available from THIS page by clicking "Browse Source Code", in this way you will access directly the SVN repository (read only mode) where the most up-to-date version is available. You can download and compile this source code, but since it is a work in progress it can contains new still unreleased features and bugs. All the information necessary to download the Source Code, configure a develop environment on the Eclipse IDE and compilerun the source code are described in the tutorial Contributing to Jaspersoft Studio and building from sources.

    See Also:

    2(5).png.4d6475e80e19e3db75aec68714c59765.png


    User Feedback

    Recommended Comments

    This page does not describe the exact process and recommendations for the installation of this software. I guess that most of the people interested in the use of Jaspersoft are BI developers and,or, users who are not familiar with OS procedures and tools used for the installation of any software. Hence, what is written on this page is of very little utility.

    • Like 2
    Link to comment
    Share on other sites

    that's a very polite way of putting it @amornard_1 .I would have been tempted to make the point a little more bluntly.   Did you have any success locating any material that would help you get started and install and configure, the community version in particular?

    Link to comment
    Share on other sites

    With the release of version 9, the Eclipse RCP package for Jaspersoft Studio has been removed, this article is, therefore, mostly inaccurate since then. Thank you for pointing that out.

    Edited by Raphaël Peguet
    • Sad 1
    Link to comment
    Share on other sites

    so for anyone looking to get help to actually get started this is my journey so far.

    I downloaded the community version and unzipped the package, I'm on windows 11 so it just used the default unzip option.  I tried to run the application but got the following error:

    Quote

    The executable launcher was unable to locate it's companion shared library

    eventually google find me a match for that on this site,

    I love how google finds things that a site search can't 😀

    Although its ten years old there was some advice on there that's quite useful... it suggested using 7-zip.  which I did.  

    This has moved me forward, to the next error 🙄

    I'm prompted to sign into the community and when I do that I get a different error:

    Quote

    javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
        at java.base/sun.security.ssl.Alert.createSSLException(Unknown Source)
        at java.base/sun.security.ssl.TransportContext.fatal(Unknown Source)
        at java.base/sun.security.ssl.TransportContext.fatal(Unknown Source)
        at java.base/sun.security.ssl.TransportContext.fatal(Unknown Source)
        at java.base/sun.security.ssl.CertificateMessage$T13CertificateConsumer.checkServerCerts(Unknown Source)
        at java.base/sun.security.ssl.CertificateMessage$T13CertificateConsumer.onConsumeCertificate(Unknown Source)
        at java.base/sun.security.ssl.CertificateMessage$T13CertificateConsumer.consume(Unknown Source)
        at java.base/sun.security.ssl.SSLHandshake.consume(Unknown Source)
        at java.base/sun.security.ssl.HandshakeContext.dispatch(Unknown Source)
        at java.base/sun.security.ssl.HandshakeContext.dispatch(Unknown Source)
        at java.base/sun.security.ssl.TransportContext.dispatch(Unknown Source)
        at java.base/sun.security.ssl.SSLTransport.decode(Unknown Source)
        at java.base/sun.security.ssl.SSLSocketImpl.decode(Unknown Source)
        at java.base/sun.security.ssl.SSLSocketImpl.readHandshakeRecord(Unknown Source)
        at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
        at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
        at org.apache.http.conn.ssl.SSLConnectionSocketFactory.createLayeredSocket(SSLConnectionSocketFactory.java:436)
        at org.apache.http.conn.ssl.SSLConnectionSocketFactory.connectSocket(SSLConnectionSocketFactory.java:384)
        at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:142)
        at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:376)
        at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:393)
        at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:236)
        at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:186)
        at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:89)
        at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:110)
        at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:185)
        at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:83)
        at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:108)
        at com.jaspersoft.studio.statistics.heartbeat.CommunityLogin.getCsrf(CommunityLogin.java:54)
        at com.jaspersoft.studio.statistics.heartbeat.CommunityLogin.verifyCredentials(CommunityLogin.java:106)
        at com.jaspersoft.studio.statistics.heartbeat.CommunityLoginDialog.buttonPressed(CommunityLoginDialog.java:269)
        at org.eclipse.jface.dialogs.Dialog.lambda$0(Dialog.java:619)
        at org.eclipse.swt.events.SelectionListener$1.widgetSelected(SelectionListener.java:84)
        at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
        at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4274)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1066)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4072)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3660)
        at org.eclipse.jface.window.Window.runEventLoop(Window.java:823)
        at org.eclipse.jface.window.Window.open(Window.java:799)
        at com.jaspersoft.studio.rcp.intro.Application.start(Application.java:96)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:136)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:402)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.base/java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:651)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:588)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1459)
    Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
        at java.base/sun.security.validator.PKIXValidator.doBuild(Unknown Source)
        at java.base/sun.security.validator.PKIXValidator.engineValidate(Unknown Source)
        at java.base/sun.security.validator.Validator.validate(Unknown Source)
        at java.base/sun.security.ssl.X509TrustManagerImpl.checkTrusted(Unknown Source)
        at java.base/sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(Unknown Source)
        ... 50 more
    Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
        at java.base/sun.security.provider.certpath.SunCertPathBuilder.build(Unknown Source)
        at java.base/sun.security.provider.certpath.SunCertPathBuilder.engineBuild(Unknown Source)
        at java.base/java.security.cert.CertPathBuilder.build(Unknown Source)
        ... 55 more
     

    slow progress here... and if that chatbot pings me once more! 🤬

    Link to comment
    Share on other sites

    I am getting the same error as you are, has anyone from Jaspersoft repsonded?

    javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    Link to comment
    Share on other sites

    Hi, if you try to search the text "javax.net.ssl.SSLHandshakeException: PKIX path building failed" in "Forums" section, you will easily find the two replies that Giulio gave to similar questions/issues.
    See here:

    Plus, if you are currently verifying the issue when trying to "register" with community credentials for starting Studio correctly, be aware that the latest version 6.21.3 implemented an alternative method. It allows to correctly register the product when some issues are verified when directly connecting to the Community site or when it's impossible.

    In the future, please refer to the "Forums" section and post there for additional issues (existing or new threads). Please don't comment under old articles that might be outdated or not properly related to the topic.

    Thanks!
    Massimo.

     

     

    Link to comment
    Share on other sites



    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×
×
  • Create New...