Jump to content
Changes to the Jaspersoft community edition download ×

compile error creating .jasper file


Recommended Posts

By: Dan Peery - sfpeery

compile error creating .jasper file

2002-09-17 10:55

Please help.

 

I ran "ant clean" against the fonts sample, then "ant javac" to create the sample class file. But, when I run "ant compile" I get the following problem>>>

 

 

C:datadownloadjavareport librariesJasperReportsjasperreports-0.4.0-project

JasperReportsdemosamplesfonts>ant compile

Buildfile: build.xml

 

compile:

[java] java.lang.UnsupportedClassVersionError: sun/tools/javac/Main (Unsupp

orted major.minor version 48.0)

[java] at java.lang.ClassLoader.defineClass0(Native Method)

[java] at java.lang.ClassLoader.defineClass(ClassLoader.java:488)

[java] at java.security.SecureClassLoader.defineClass(SecureClassLoader

.java:106)

[java] at java.net.URLClassLoader.defineClass(URLClassLoader.java:243)

[java] at java.net.URLClassLoader.access$100(URLClassLoader.java:51)

[java] at java.net.URLClassLoader$1.run(URLClassLoader.java:190)

[java] at java.security.AccessController.doPrivileged(Native Method)

[java] at java.net.URLClassLoader.findClass(URLClassLoader.java:183)

[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:294)

[java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:281)

 

[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:250)

[java] at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:310)

 

[java] at java.lang.Class.forName0(Native Method)

[java] at java.lang.Class.forName(Class.java:115)

[java] at dori.jasper.engine.design.JRCompiler.compileClass(JRCompiler.

java:194)

[java] at dori.jasper.engine.design.JRCompiler.compileReport(JRCompiler

.java:126)

[java] at dori.jasper.engine.JasperCompileManager.compileReportToFile(J

asperCompileManager.java:129)

[java] at dori.jasper.engine.JasperCompileManager.compileReportToFile(J

asperCompileManager.java:101)

[java] at FontsApp.main(FontsApp.java:126)

[java] Exception in thread "main"

[java] Java Result: 1

 

BUILD SUCCESSFUL

Total time: 4 seconds

C:datadownloadjavareport librariesJasperReportsjasperreports-0.4.0-project

JasperReportsdemosamplesfonts>C:datadownloadjavareport librariesJasperR

eportsjasperreports-0.4.0-projectJasperReportsdemosamplesfonts

 

 

By: Dan Peery - sfpeery

RE: compile error creating .jasper file

2002-09-17 15:21

Answer: My JAVA_HOME was pointing to "c:jdk1.3.1_04" and needed to be pointing to "c:j2sdk1.4.0_01".

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...