Jump to content
Changes to the Jaspersoft community edition download ×

Compatibility question


Recommended Posts

Hi,

I have a question: Is it generally not possible to execute a .jasper file with Jasperreport libraries that are newer than the Jasperstudio version that was used to compile the reports (using current version compatibility settings).

I'm asking, because I have reports that I generated and compiled with Jasperstudio 6.2.1. As long as I used Jasperreport libraries 6.2.1 everything was fine. But I had to upgrade to a newer version 6.7.0 of the libraries. Some of my reports still execute fine. But there are some that fail with a ClassNotFound error (JRBshCompiler).

I tried use the latest version of JasperStudio to compile the reports to version 6.6.0 (there is no 6.7.0). But I constantly get ClassNotFound error in JasperStudio when compiling with the compatibility settings. I don't know what I'm doing wrong here.

Does anybody have an idea how to solve my problem?  Any help is greatly appreciated!

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

I have an update: I solved the issue with the JRBshCompiler not found error. This was because some of my reports had the language setting "bsh" for report expressions set. I changed it to "java" and now it runs fine with Jasperreport 6.70 even so it was compiled with Jasperstudio 6.2.1.

But the compatibility setting in Jasperstudion 6.21.2 still does not work for me. So if anybody has some info, that would be heldful.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Anuja,

Thanks for the link. I actually used that before to set the compatibility . I now added all dependency libraries to the directory of my 6.7.0 jasperreports libraries. That solved a lot of classnotfound errors. But I still have to deal with one issue that "java.lang.System" type can't be resolved to a type.

Maybe as info: I have set the compiler compliance level to 1.8, because that's the version we are working with. But even if I set it to 17, I still get the same error.

Any ideas?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...