Jump to content
Changes to the Jaspersoft community edition download ×

Different sorting on windows and linux [solved]


MUC_pl_sql
Go to solution Solved by MUC_pl_sql,

Recommended Posts

I use two Jasper servers. My development environment, a jasperserver and jasperstudio, run on a windows computer. My productive environment runs on a Linux server. 
Both access an oracle database. The Oracle SQL server sorts according to the property "NLS_SORT = German" 
This results in the following sorting 
 
! _ a A ä b B c C ö ß ü 1 2 3
 
In my query I sort the result with an "order by"
I develop my reports in jasperstudio. The sorting is displayed correctly there.
When I run the report in jasperstudio or upload it to my development server. Is the sorting displayed correctly?
Now I have the problem that the sorting on the Linux server behaves differently than on the windows computer. 
In the LinuxServer it seems to be using binary sorting. Which leads to the following sorting. 
 
1 2 3 A B C _ a b c ß ä ö ü
 
Does anyone have an idea why the sorting on a Linux system doesn't take the setting of the database. When I run the query in SQL Developer, the correct sorting is used.
 
Thanks in advance
 

 

 

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Thank you for posting to the Jaspersoft Community. Our team of experts has read your question and we are working to get you an answer as quickly as we can. If you have a Jaspersoft Professional Subscription plan, please visit https://support.tibco.com/s/ for direct access to our technical support teams offering guaranteed response times.
 

Link to comment
Share on other sites

  • Solution

I found a solution. first i thought i have to change the system locale from linux.

But this didnt make a change.

The Solution was to add some java parmeters to the startup of the tomcat.

So i added -Duser.language=de -Duser.region=DE  to the SETENV script of  the tomcat [jasperserver]/apache-tomcat/bin/setenv.sh

after the last line containing java_opts i added

JAVA_OPTS="-Duser.language=de -Duser.region=DE $JAVA_OPTS " # java-locale settings

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...