Jump to content

WAR file installation for Community JasperServer 8 failing


andrew_50

Recommended Posts

The instructions I have been following, which I believe worked in the past, are now failing on me.
Probably down to me.
 

What I did (my instructions to self) are below.

The install all seems to be ok, but fails on the line      sudo ./js‑ant import-minimal-ce

 

The error/build log is...

Buildfile: /home/tomcat/jasperreports-server-cp-8.1.1-bin/buildomatic/build.xml
     [exec] Result: 128
     [echo] Back-End version: fatal: not a git repository (or any of the parent directories): .git-SNAPSHOT
     [echo] Front-End version: fatal: not a git repository (or any of the parent directories): .git-SNAPSHOT
     [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands
     [echo] Maven settings: /home/tomcat/jasperreports-server-cp-8.1.1-bin/buildomatic/build_conf/default/maven_settings.xml

import:
     [echo]
     [echo] The property -DimportFile needs to be specified on the command line
     [echo] For instance:     js-ant import -DimportFile=js-catalog.zip
     [echo] For options try:  js-ant import-help-pro
     [echo]                     

BUILD FAILED
/home/tomcat/jasperreports-server-cp-8.1.1-bin/buildomatic/bin/import-export.xml:230: The following error occurred while executing this line:
/home/tomcat/jasperreports-server-cp-8.1.1-bin/buildomatic/bin/import-export.xml:46: Missing file argument for import/export

Total time: 5 seconds

Drawing a blank as to what's wrong here.
Not sure why git is even a consideration.

 

 

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...