Jump to content
We've recently updated our Privacy Statement, available here ×

Locale encoding translation problem


filip.banaszek
Go to solution Solved by filip.banaszek,

Recommended Posts

Hey, Im trying to make a translation of labels for Polish locale. So I've made a jasperserver_messages_pl_PL.properties with translated some of the labels and made polish locale available.

The labels changed but I've encountered a problem with character encoding, some of special polish characters are messed up, for example "Zarządzaj" looks like "ZarzÄdzaj"

Thanks in advance!

Found a similar question but cannot find the linked answer:

https://community.jaspersoft.com/questions/539361/jasperserver-localization-what-wrong

Link to comment
Share on other sites

  • 1 month later...
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Can you try to switch the encoding to UTF-16 to see if you get a better result?

In.../WEB-INF/applicationContext.xml

Change the default "UTF-8" . For example:


<bean id="encodingProvider" class="com.jaspersoft.jasperserver.api.common.util.StaticCharacterEncodingProvider">
<constructor-arg value="UTF-16" />
</bean>

Hope it helps

 

Link to comment
Share on other sites

  • Solution

Hey Everyone!

I eliminated this problem using mobilefish.com unicode characters to unicode escape sequences and it worked for me. When you look into other files, especially asian fonts uses the same technique to code characters. I hope if anyone will encounter the same problem will find this fix :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...