Jump to content
Changes to the Jaspersoft community edition download ×

$X parameter not working


johnny.cash
Go to solution Solved by danoldenkampgmail.com,

Recommended Posts

Good Day

in a report I have a dataset with a query of this sort:

    SELECT stuff
    FROM table
    WHERE $X{IN, column, dm_parameter}

I have sucessfully used similar queries on a MSSQL database with the exact same WHERE clause.

I created a PostgreSQL datasource and run other queries on it successfully.

But when I run this query it returnes ALL rows, as if the WHERE condition would not exist.

The dm_parameter is of Class java.util.ArrayList.

Any ideas what I am doing wrong or how to troubelshoot it?

Thank you

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...