Jump to content
Changes to the Jaspersoft community edition download ×

Parameters not being published on Jasper Server


JS-newbie

Recommended Posts

Hello. 

I developed a report in JasperSoft Studio and published it to the server . The report's parameters didn't get published. While publishing, I've noticed in Studio that Resources list is empty.

How can I make JS Studio pick and publish my parameters ? There are some internal parameters that need to be deployed. Thanks!

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

If you want to deploy via Jasper Studio, you need to first create conneciton to your server. 
So make use of the Repository Explorer, under Server, add your japser server, url, user, password etc.
Then after connection succesfully created, you will be able to browser the Jserver repository. 
So then just right click and add new > report unit, then under the report unit add your resource i.e. new > input control etc.

Otherwise you can deploy via jasperserver gui. 
You can either create the resource to be reused across reports or you can create the resource element i.e. Input control within the report element when you deploy the report.
i.e. under the Controls & Resources tab. 

Hope this helps.


 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...