Jump to content
Changes to the Jaspersoft community edition download ×

Error when creating a single or multi select query input control


thomasstoops

Recommended Posts

At a client, when trying to adjust or create a single or multi select query input control the following error is shown:

org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Unexpected failure during bean definition parsing Offending resource:  ServletContext resource [/WEB-INF/flows/queryBeans.xml] Bean 'editQueryAction';nested exception is org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: <property> element for property 'queryLanguages' is only allowed to contain either 'ref' attribute OR 'value' attribute OR sub-element Offending resource:  ServletContext resource [/WEB-INF/flows/queryBeans.xml] Bean 'editQueryAction' -> Property 'queryLanguages'[/code]

Error Trace

org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Unexpected failure during bean definition parsing Offending resource:  ServletContext resource [/WEB-INF/flows/queryBeans.xml] Bean 'editQueryAction'; nested exception is org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: <property> element for property 'queryLanguages' is only allowed to contain either 'ref' attribute OR 'value' attribute OR sub-element Offending resource:  ServletContext resource [/WEB-INF/flows/queryBeans.xml] Bean 'editQueryAction' -> Property 'queryLanguages' at org.springframework.beans.factory.parsing.FailFastProblemReporter.error(FailFastProblemReporter.java:68) at[/code]

When checking the queryBeans.xml file I don't see anything unusual? Below the xml file structure 

<?xml version="1.0" encoding="UTF-8"?>-<beans xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.1.xsd http://www.springframework.org/schema/util http://www.springframework.org/schema/util/spring-util-2.0.xsd"        xmlns:util="http://www.springframework.org/schema/util"        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"        xmlns="http://www.springframework.org/schema/beans">    <!-- Backing action for edit query flow -->    <!-- README README README -->    <!-- This file is overwritten by the pro version -->    <!-- README README README -->    -<bean class="com.jaspersoft.jasperserver.war.action.EditQueryAction" id="editQueryAction">        -<property name="repository">             <ref bean="${bean.repositoryService}"/>         </property>         <property name="queryLanguages" ref="queryLanguages"/>         <property name="queryLanguagesRequestAttrName" value="queryLanguages"/>         <property name="validator" ref="queryValidator"/>         <property name="dataSourceTreeDataProvider" ref="dsTreeDataProvider"/>         <property name="messages" ref="messageSource"/>         <property name="configuration" ref="configurationBean"/>         <property name="customDataSourceFactory" ref="customDataSourceServiceFactory"/>     </bean>    -<bean class="com.jaspersoft.jasperserver.war.validation.QueryValidator" id="queryValidator">        -<property name="repository">             <ref bean="${bean.repositoryService}"/>         </property>     </bean>    <import resource="repositoryExplorerBean.xml"/></beans>[/code]

Product Version: 5.5.0

Build: 20131024_0957

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

So when exactly is this happening and where ? 
When creating inputcontrol or after creating inputcontrol, then linking to report, then when running the report ? 
Then are you doing this via JasperServer Gui or via Jasper Studio via repositorty explorer ? 

So I took the above code, as is and copied into my JasperServer 6.4.0  queryBeans.xml file, restarted my server and then created an single select query input control with not issues. (You would think it would not have worked as you are using version 5.5.0)
Which leads me to think you might have another code issues somewhere else. Maybe look though the Apache tomcat logs to see if some beans are not being uploaded on startup etc. Look at any files that you or someone else might have edited, there could be a simple coding validation issues or error that is a cascading cause of this one.
Maybe you have permission issues on your files where the jasperserver is installed. Maybe a files chmod or chown or something was changed by accident. 
Could be that there is something in the query that is not being validated that should have generated a more specific error and this error is just a cause if that lack of validations? 

Did you try to reproduce the same input controls on another jasper instance? Did you get the same results?  
Good luck on this one, I am sure your find it after eliminating possible causes, one by one.

Link to comment
Share on other sites

It happens when creating or editing a data input control in the jasper server GUI, as mentioned above I can't reproduce the problem on a diff version, only happens in 5.5.0.

e.g. the error appears when creating a new single select query input control filling in the name, clicking next, then selecting "Define a query in the next step" radiobutton, clicking next, and then the error appears.

Permissions is not the issue, already checked that, due to trying this with admin accounts. 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...