Jump to content
Changes to the Jaspersoft community edition download ×

Input Control for Multiselect String parameter


Recommended Posts

Hello All,

I have a report which has three sub reports in it and All of them has a Multi select parameter which is String datatype.

when i run the main report it runs fine from studio. but, When i run it from  Server it throws me below error.

Invalid type java.lang.String for parameter glid used in an IN clause; the value must be an array or a collection.

I declared the field as Collection type with String data type. The field which i declared as STRING is varchar field in DB (SQL Server)

Input control : It is single select query ehere VLAUE & LABEL are both the same fields (String field).

Please help me out how to proceed with this kind of issue or where i am doing wrong.

 

Regards,

Manasa

 

Link to comment
Share on other sites

  • 5 years later...
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Issue:

1) Report "has a Multi select parameter which is String datatype", such as ["USA",...]

2) "Input control : It is single select query", therefore the value is "USA".

 

Problem:

Can not use single select input to feed report collection parameter. "USA" -->  ["USA",...], incorrect.

 

Resolution:

Use MULTI select input control instead.  ["USA",...] -->  ["USA",...]

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...