Jump to content
Changes to the Jaspersoft community edition download ×

Problem customizing the home page


jlongoria

Recommended Posts

I customized the homepage so that users with ROLE_DOMAIN_DESIGNER will see the quicklinks for Reports, Dashboards, Ad-hocs and Domains. I did this by modifying applicationContext-rest-services.xml

It mostly worked, but the quicklink for Domains only has the View List link, not the Create link. Please see screenshot.

Why is this happening? How can I fix it?

 

domain-link-missing.png.d13432644d16517ee69704eb250cf6e5.png

Here are my changes to the file:

<bean class="com.jaspersoft.jasperserver.jaxrs.poc.hypermedia.workflow.service.WorkflowsSecurityFilter">
                    <property name="supportedAttribute" value="SEE_DOMAINS_ALLOWED"/>
                    <property name="allowedRoles">
                        <util:list>
                            <value>ROLE_ADMINISTRATOR</value>
                            <value>ROLE_DOMAIN_DESIGNER</value>
                        </util:list>
                    </property>
                    <property name="workflowsToSecure">
                        <list>
                            <value>domain</value>
                        </list>
                    </property>
                </bean>
Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

Posted Images

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...