Jump to content

Adhoc creation killed my AWS instance

Go to solution Solved by rmiller,

Recommended Posts

I have a m1.medium aws instance running jasperserver. I have created a domain with the relational schema between my tables, and I have tried opening Ad-Hoc view to see if everything went ok. However, since then (it's been a bit over 3 hours) my aws is not responding. 

My best guess would be that the server tried to read everything from the given tables, and it caused cpu overload, but I have no clue what might have caused this.


I am trying to reboot the machine right now, but with no success. Any clues on what might have caused this so I can avoid it in the future?


the procedure was:

- create a domain, adding the tables that interest me (biggest one has 11M rows). Making all the joins with these tables and putting the desired fields on display. (works fine)

- creating an adhoc view, selection the domain, adding to view and jumping to chart/crosstab view (works fine)

- selecting some fields and filters. (crashes).

Link to comment
Share on other sites

  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

These are a bit of the logs

2014-07-17 12:48:40,164 ERROR errorPage_jsp,http-bio-80-exec-41684:573 - stack trace of exception that redirected to errorPage.jsp

org.springframework.webflow.conversation.impl.LockTimeoutException: Unable to acquire conversation lock after 90 seconds

at org.springframework.webflow.conversation.impl.JdkConcurrentConversationLock.lock(JdkConcurrentConversationLock.java:44)

at org.springframework.webflow.conversation.impl.ContainedConversation.lock(ContainedConversation.java:69)

at org.springframework.webflow.execution.repository.support.ConversationBackedFlowExecutionLock.lock(ConversationBackedFlowExecutionLock.java:51)


2014-07-17 14:13:57,025 ERROR errorPage_jsp,http-bio-80-exec-41790:573 - stack trace of exception that redirected to errorPage.jsp

com.jaspersoft.jasperserver.api.JSException: java.lang.OutOfMemoryError: Java heap space

Link to comment
Share on other sites

  • Solution
You have only 4 GB RAM on an m1.medium instance, which is minimal for large data sets like yours. 
Most of the OOMs (OutOfMemoryError) before today are in the PermGen space so you will have to increase that, you probably have 512M at this time, increase it to 1024M. 
Starting today the OOMs are all in the heap space, which is what caused the server to freeze. You probably have only 2 GB maximum heap which is way to small to handle 11M row result sets. 
It looks like you will have to move to a larger EC2 instance with enough RAM to handle your needs.
Link to comment
Share on other sites

Thank you for your reply. I assumed it had something to do with my instance. I was wondering if you could give me an estimate on which instance would be required to run this data set, so I could check if it would be worth upgrading or mantaining the derived table queries in the current instance, since they work with this instance (but with less interactivity for the end user).


As I mentioned before, we are pulling data from 7 tables and the largest ones have 11M and 7M rows.

Link to comment
Share on other sites

I have attached a file with information about AWS instance sizes. I would say that the minimum you will need is is an m1.large with 7.5 GB RAM.

BTW, AWS is moving to the M3 instances. You should consider for yourself. Here's what AWS says about it:

"M3 instances provide better, more consistent performance than M1 instances for most use-cases. M3 instances also offer SSD-backed instance storage that delivers higher I/O performance. M3 instances are also less expensive than M1 instances. Due to these reasons, we recommend M3 for applications that require general purpose instances with a balance of compute, memory, and network resources."


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...