Jump to content
Changes to the Jaspersoft community edition download ×

problem running on i-planet


Recommended Posts

By: Steven Blough - stevenblough

problem running on i-planet

2002-02-19 06:11

I am trying to run the letter.jsp example on I-planet and I am receiving a blank page back into the browser.

I then separated the steps for generating the report and found the following messages.

 

“JasperReports :: File reportFile = new File(application.getRealPath("/JasperReportsLetter.jasper"));”

“JasperReports :: JasperReport jrReport=JasperManager.loadReport(reportFile.getPath());”

[Loaded java/io/ObjectInputStream.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/ObjectInput.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/ObjectStreamConstants.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/Externalizable.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/ObjectStreamClass$1.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/NoSuchFieldException.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/reflect/Field.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/reflect/Modifier.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/Byte.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/Short.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/ObjectStreamClass$2.class from /usr/java/jre/lib/rt.jar]

[Loaded java/security/MessageDigest.class from /usr/java/jre/lib/rt.jar]

[Loaded java/security/MessageDigestSpi.class from /usr/java/jre/lib/rt.jar]

[Loaded java/security/Security$ProviderProperty.class from /usr/java/jre/lib/rt.jar]

[Loaded sun/security/provider/SHA.class from /usr/java/jre/lib/rt.jar]

[Loaded java/security/MessageDigest$Delegate.class from /usr/java/jre/lib/rt.jar]

[Loaded java/security/DigestOutputStream.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/ObjectStreamClass$MethodSignature.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/Void.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/NoSuchMethodException.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/ObjectOutputStream.class from /usr/java/jre/lib/rt.jar]

[Loaded java/io/ObjectOutput.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/Color.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/Paint.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/Transparency.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/Toolkit.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/Toolkit$3.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/PaintContext.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/color/ColorSpace.class from /usr/java/jre/lib/rt.jar]

[Loaded java/text/ParsePosition.class from /usr/java/jre/lib/rt.jar]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[signaling Error: error already pending]

[Loaded java/util/HashMap$3.class from /usr/java/jre/lib/rt.jar]

“JasperReports :: JasperPrint jrPrint=JasperManager.fillReport(jrReport,parameters,new JREmptyDataSource());”

[Loaded java/util/HashMap$1.class from /usr/java/jre/lib/rt.jar]

[Loaded java/text/CharacterIterator.class from /usr/java/jre/lib/rt.jar]

[Loaded java/awt/GraphicsEnvironment.class from /usr/java/jre/lib/rt.jar]

[Loaded sun/awt/X11GraphicsEnvironment.class from /usr/java/jre/lib/rt.jar]

[Loaded sun/java2d/SunGraphicsEnvironment.class from /usr/java/jre/lib/rt.jar]

[Loaded sun/awt/font/NativeFontWrapper.class from /usr/java/jre/lib/rt.jar]

[Loaded java/lang/InternalError.class from /usr/java/jre/lib/rt.jar]

[Loaded sun/io/CharacterEncoding.class from /usr/java/jre/lib/rt.jar]

 

I am running with the following software versions:

JasperReports 0.2.4

iText 0.73

Java 1.2.2

Solaris 2.8 w/ xServer Installed

i-planet 4.1 serv pack 7

 

If you have any insight into the possible cause or a direction that I should continue looking I would appreciate it.

 

Thanks

Steven Blough

 

 

 

 

By: Steven Blough - stevenblough

RE: problem running on i-planet

2002-02-19 10:23

I forgot to mention that it works fine in tomcat 4 on windows 2000

 

Thanks

Steven Blough

 

 

By: Teodor Danciu - teodord

RE: problem running on i-planet

2002-02-24 04:40

 

Hi,

 

I have experienced similar problems when

using Internet Explorer.

Somehow, it does not how to display the

PDF content it receives.

 

Acrobat Reader has a setting that tells him

if it should launch in the browser's window

or in a separate one. Try to modify this setting.

 

Maybe you can find more details on the iText site.

 

Also, try to use other browsers to see

if the problem persists.

 

Thanks,

Teodor

 

 

 

By: Steven Blough - stevenblough

RE: problem running on i-planet -solved

2002-02-25 09:27

This actually ended up being a problem with the XServer not being installed and the classpath not being correct. I solved the problem by having Xvfb installed on the server because installing XServer wasn’t an option.

 

Thanks

Steven Blough

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...