Jump to content
Changes to the Jaspersoft community edition download ×

new to iReports


vanyard

Recommended Posts

Hi all :) ,

 

 

I have installed iReports, and at the wizard,I created a new report, but when I choose to run the report from "execute with active connection" the report wont run although I added the callses12.jar file to be able to create Database connection.

 

And as mentioned in the subject, I am new to iReports, I have installed iReports to able to create Jasper reports and call them in my application, I am designing an ADF&JSF web application, so if there any links/tutorials regarding this subject it would be great too.

 

Thanks all,

Ahmad Esbita

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

It might also be helpful if you post the first part of any error message you are getting.

 

 

Also make sure that tools.jar is available in your classpath. This component is required to run iReports but is not part of the distribution.

Link to comment
Share on other sites

Well spotted! But not necessarily correct: that would depend on which version of iReports is being run. Older versions using Java 1.2 or lower required classes12.jar. Newer versions of iReport (around version 1.2.3 and beyond) were deployed with methods from Java 1.4 and later Java 1.5. This forced a change to ojdbc14.jar

 

For more info on which one to use refer to this thread on the sun forums http://forum.java.sun.com/thread.jspa?threadID=688414&messageID=4004973

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...