Jump to content
Changes to the Jaspersoft community edition download ×

Export parameters from JasperServer


scottmacpherson

Recommended Posts

I'm having problems with leading zeros being excluded from reports which are exported to Excel, and having read all the threads in this forum on the subject I know I should consider fidding with the IS_DETECT_CELL_TYPE parameter.

Problem is, I don't know where to set this parameter.

I'm creating reports using iReport, and then placing them on a JasperServer server, which is then accessed by users using a web browser.

It sounds like I need to change the export parameter on the JasperServer side of things, and not in the actual report JRXML. If I'm correct, can someone point me in the right direction?

Many thanks.

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Hi,

 

In a couple of days we'll make available the JasperServer 2.0 open source release. Your problem will be solved when you will download this version. Until then, keep in mind that the only thing you have to do to set your IS_DETECT_CELL_TYPE parameter is to modify as you wish, in the viewReportBeans.xml file, the "detectCellType"'s property value of the "xlsExportParameters" bean.

 

sanda

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...