Jump to content
Changes to the Jaspersoft community edition download ×

Error in running samples


sgarg

Recommended Posts

I am newbie to jasper reports. I have installed Jasper report 1.2.7, ant and java on my system. "ant -p" does not work for me rather I compiled with Ant. When I tried to run some samples, it is giving me error some thing like this "Exception in thread "main" java.lang.NoClassDefFoundError:net/sf/jasperreports/engine/JRException"

I am not able to run any of the samples. Please suggest me what should I do..Is there anything in environment variable...

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Hi Teodor

I built the root directory with "ant jar", it built successfully. Can you please help me in how to run samples now. Do I need to run with "java class name" if yes Still I am getting same error. Or there is another way to run all the samples. It is very crucial for me, we have to take decision in implementing Jasper reports in current product..

 

Thanks

Link to comment
Share on other sites

Hi,

 

I don't know what do you mean by installing JasperReports. There is nothing to install, just unpack the distribution in a folder.

I just hope you did not move files around.

If you did not, and you let the unpacked JR alone, you should be able to run the samples with no problem.

 

I also don't see why the "ant -p" does not work and you did not sent us any error message.

Ant is supposed to make things easier. If it does not work for you, I'm afraid I cannot help.

 

Thank you,

Teodor

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...