Jump to content
Changes to the Jaspersoft community edition download ×

JasperReport 1.2.1 and Acrobart 6.0 problem


pajarokillo

Recommended Posts

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Ok, excuse me, i might have detailed more my problem. I execute my report from a servlet, and i set the content type to "application/pdf". Then, from my Jsp page i open a window that call to servlet and display the report in PDF format. I have installed Acrobat 7.0 and it works correctly, i can see my report, but when i try it in other machine that it has installed Acrobat 6.0 or less, it don't work, the report is blank, and it don't give me any exception.

 

I don't know if i explain me better, my english isn't good.

 

Thanks.

Post edited by: pajarokillo, at: 2006/09/27 13:25

Link to comment
Share on other sites

yes, i had already exported to a in-memory buffer and set the content length for the response, my portion of code when i do that is the following:

 

byte[] bytes = null;

bytes = report.getReport();

if(bytes != null && bytes.length > 0){

response.setContentType("application/pdf");

response.setContentLength(bytes.length);

ServletOutputStream outputStream = response.getOutputStream();

outputStream.write(bytes,0,bytes.length);

outputStream.flush();

outputStream.close();

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...