Jump to content
Changes to the Jaspersoft community edition download ×

PDF Embedded Fonts


m2calabr

Recommended Posts

I am using JasperServer 0.92 and I am having problems using embedded fonts. I am willing to upgrade to the newest version of JasperIntelligence, but I wanted to make sure that 1) I have the right idea and 2) it works in the new version.

 

I have:

1) Create a fonts folder (off the root) in the repositor.

2) In the report unit, tried using the font from the fonts folder.

3) In the report unit, tried upload the font directly there.

 

To try and access the font I have tried in the pdfFontName:

1) repo:arialbd.ttf

2) repo:/arialbd.ttf

3) repo:/fonts/arialbd.ttf

4) repo:fonts/arialdb.ttf

 

So am I on the right path? Does it work in the version that I have? The new version? Have I missed the boat? ;)

 

---------XML Example from report-----

Code:

<font fontName="Arial" pdfFontName="repo:arialbd.ttf" size="28" isBold="true" isPdfEmbedded ="true"/>

-------------------------------------

Note:

Yes, I know that Helvetica is very close to Arial. I have other more specialized fonts that I need. This is just an example.

 

Thanks for you help

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

This functionality was implemented after the 1.0.1 release, therefore it will only be available in the next release.

 

In the meantime, you need to use alternative ways of accessing your fonts, e.g. packing them into a jar placed on your application's classpath and referring to them as class loader resources.

 

Regards,

Lucian

Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...