user, role and permission

JasperReport Server 5.5 Pro

I created a new role and named it role_specific. Then I created a new user and assigned this role_specific to him. (By default, this user got ROLE_USER role as well.)

At this point, this user can see and run a report stored in ROOT/reports/dev/ folder.

Then I removed his ROLE_USER role. (only role_specific is left) I went to repository -> root and gave Read Only access to role_specific. 

Then I tried to run the report 

a.) switched my super user account to this user, I can see NOTHING.

b.) tried to run the report from my php application (embedded in iframe), I got permission denied error.

What else do I need to do to manage users with roles ?

My report is created in this way:   DataSource (mysql) -> Domain -> Ad Hoc View -> Report.  Is there anything generated and stored outside of Repository->root ?

Thanks

Justin_6's picture
Joined: Feb 24 2014 - 2:07pm
Last seen: 8 years 9 months ago

1 Answer:

Make sure that the role has execute permissions on all of the resources used by the report.  For visibility to the report, make sure that they have read access to all of the subdirectories too.  See if that works.

mgeise's picture
44461
Joined: Mar 5 2007 - 6:18am
Last seen: 3 years 3 months ago

Since the Read Only access is given to Repository->Root, all sub-directories are given Read Only access as inherited permission. (It shows like 'Read Only*' in the dropdown.)

I found another thread posted earlier, and looks like we can't remove ROLE_USER for any newly created user. It's a MUST HAVE role.

Justin_6 - 8 years 9 months ago
Feedback
randomness