Failure to find org.olap4j:olap4j:jar:0.9.7.309-JS-3

6

I am trying to embed JasperReports in an application. I use Maven to handle the project dependencies and have added net.sf.jasperreports:jasperreports as a dependency.

I have added the JasperReports Maven repository to Nexus according to http://community.jaspersoft.com/jasperreports-library/issues/2594-0 so that Maven can retrieve some artifacts. The problem is that it the following artifact is missing from http://jasperreports.sourceforge.net/maven2/ org.olap4j:olap4j:jar:0.9.7.309-JS-3

Is this on purpose? Should I proceed differently to embed JasperReports? Is that artifact actually necessary if I only need to use JasperReports Library functionalities?

I have worked around the issue by downloading the jasperreports-server bin, getting the missing jars and adding them to our nexus.

 

 

rros_1's picture
34
Joined: May 12 2014 - 6:10am
Last seen: 4 years 10 months ago

1 Answer:

5
mailtoarlo's picture
Joined: May 21 2014 - 1:42am
Last seen: 4 years 3 weeks ago

I have the same issue and tried to proxy this repository you mention. Nexus complains that the repository does not publish an index and can't be included in the public aggregated index. What are your thoughts on addressing this issue?

barrina - 4 years 3 weeks ago

You should ask this on a Nexus related mailing list. We use artifactory.

mailtoarlo - 4 years 3 weeks ago
Feedback
randomness