Jump to content
Changes to the Jaspersoft community edition download ×

Failure to find org.olap4j:olap4j:jar:

Go to solution Solved by mailtoarlo,

Recommended Posts

I am trying to embed JasperReports in an application. I use Maven to handle the project dependencies and have added net.sf.jasperreports:jasperreports as a dependency.

I have added the JasperReports Maven repository to Nexus according to http://community.jaspersoft.com/jasperreports-library/issues/2594-0 so that Maven can retrieve some artifacts. The problem is that it the following artifact is missing from http://jasperreports.sourceforge.net/maven2/ org.olap4j:olap4j:jar:

Is this on purpose? Should I proceed differently to embed JasperReports? Is that artifact actually necessary if I only need to use JasperReports Library functionalities?

I have worked around the issue by downloading the jasperreports-server bin, getting the missing jars and adding them to our nexus.



Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

  • 9 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...