jasperserver's intallation on Linux working with mysql

0
Hello everybody! I would like some help about how to install jasper server on Debian running with mysql. I tried to follow the JasperReports-Server-CP-Install-Guide's steps. I've installed the jdk1.7.0 into a directory(/opt/java-oracle), the tomcat6(/opt/tomcat6) and after that, the jasperserver (/opt/jasperreports-server-cp-5.5.0-bin). I configured the java_home, and I believe I've done all necessary steps. I'm able to login into jasperserver, althought the report's sample doesn't work correctly, I mean, it seems stay in "looping". Can anyone help me to understand how to make the correction?
igordscoelho's picture
Joined: Oct 16 2013 - 10:34am
Last seen: 1 year 7 months ago

3 Answers:

0

The install steps you did look pretty good. 

I think the thing to do is to take a look at the logs seen inside of tomcat. From here:

/opt/tomcat6/logs (might be here, but you might have to hunt around for the location). 

Then look at the catalina.out log file. There should be an error message in there. And you can post the log to this topic. 

 

tkavanagh's picture
3733
Joined: Jul 7 2006 - 8:54am
Last seen: 5 years 6 months ago

Thank you very much. I found a lot of log's file and I'm gonna post here the last one.

igordscoelho - 5 years 11 months ago
0
If you could help me, I would appreciate it.
Attachments: 
AttachmentSize
Binary Data localhost.2014-04-22.log80.44 KB
igordscoelho's picture
Joined: Oct 16 2013 - 10:34am
Last seen: 1 year 7 months ago
0

Hi, I took a look at your log file and I see two issues.

 

1) there seems to be a problem with the (sub-system) that runs JasperServer diagnostics (but it might be the case that everything keeps running ok despite this error)(ie it's not a "fatal" error). The default diagnostics port is 10990. And in the log it gives an error message that that port is in use. Maybe there is an application using that port already. You can set <tomcat>/webapps/jasperserver/WEB-INF/js.diagnostic.properties and change "diagnostic.port = 10990" to "diagnostic.port = 10999"

2) You are getting a Java out of memory error. This is a fatal error. And you can fix it by setting JAVA_OPTS memory settings in your tomcat script. I know that sounds a little intimidating ;-)  but it is actually straight-forward to do. It is fully described in Chapter 6 of the Install Guide. Which you can find at <js-install>/docs/JasperReports-Server-Install-Guide.pdf.

tkavanagh's picture
3733
Joined: Jul 7 2006 - 8:54am
Last seen: 5 years 6 months ago

Guy, I've no words to thank you... It's everything okay now... I've just changed the diagnostic.port as you told me and replaced the JAVA_OPTS on catalina.sh file as well... I have been working so long with that application and now, I believe I know everything I need to go ahead. Thank you very much!

igordscoelho - 5 years 10 months ago
Feedback
randomness