Cant open chart for editing

0

Hello,

I cant seem to be able to open a chart that exists in jasperserver repository in jaspersoft studio. 

It is not only chart that i have created but even the sample charts reports exising on the server can not be opened. 

In order to replicate connect to jasperserver in studio, locate sample reports and right click on the jrxml report and select open for editing.

You will get an error :

 

net.sf.jasperreports.engine.JRException: org.xml.sax.SAXParseException; lineNumber: 40; columnNumber: 156; schema_reference.4: Failed to read schema document 'http://jaspersoft.com/schema/fusion.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
at net.sf.jasperreports.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:293)
at com.jaspersoft.studio.editor.JrxmlEditor.doInitModel(JrxmlEditor.java:569)
...
 
I think it is not happy with the following line <fc:chart xmlns:fc="http://jaspersoft.com/fusion" xsi:schemaLocation="http://jaspersoft.com/fusion http://jaspersoft.com/schema/fusion.xsd" type="Bar">
 
but i do not understand why that would be . 
 
I have tried ireport and i get the same error. 
 
If someone could let me know how i could open a chart report for editing it would be great. 
 
Thanks
 
oakrami's picture
30
Joined: Nov 1 2013 - 4:05am
Last seen: 6 years 10 months ago

0 Answers:

No answers yet
Feedback
randomness