Installation error - symbolic links

0

I'm trying to install JasperReports Server on an Amaxon Linux AMI, but part way through the install I get the following message:

Unable to create symbolic link /opt/jasperreports-server-cp-5.5.0/postgresql/bin/postmaster -> postgres
Abort, Retry, Ignore ? [A/r/i]

I can tell it to ignore, but after nine variations of this with different files, I get this:

Error: There has been an error.
Error creating dynamic link  postgres
/opt/jasperreports-server-cp-5.5.0/postgresql/bin/postmaster
Press [Enter] to continue :

I'm running the installer as the superuser, so I don't believe there's any permissions issues, and I'm just taking the defaults for most of the installation options, except for not taking the sample databases and reports, so I don't think I'm doing anything outlandish. There's not much else installed on the server, so I don't believe there should be any conflicts, although I suppose there could be something I should have installed and haven't yet.

Has anyone seen similar errors? Can anyone tell me what I'm doing wrong?

nickmaher84's picture
Joined: Feb 18 2013 - 3:01pm
Last seen: 6 years 2 weeks ago

3 Answers:

2

Checked instalation of jasperreports-server-cp-5.5.0-linux-x64-installer.run

on new Amazon Linux 64 bit system

everything vent smooth

how to do that:
loging to EC2 using "ec2-user" account via ssh

change folder where you want to download package

"cd /tmp"

download package to current folder
"wget URL_FOR_DOWNLOAD"

change permissions on file for execution
"chmod ugo=rwx jasperreports-server-cp-5.5.0-linux-x64-installer.run"

execute installer with elevated permissions"
"sudo ./jasperreports-server-cp-5.5.0-linux-x64-installer.run"

folow instalation instructions

after succesfull install run installed tomcat with elevated permissions
"cd /opt/jasperreports-server-cp-5.5.0/"
"sudo ./ctlscript.sh start"

make sure you have port 8080 allowed in AWS "EC2 Security Group"

open browser and point to instance http://DNS_NAME:8080/jasperserver

enjoy.

 

i was trying to reproduce your ptoblem - but everything works,
if you still need help - include "/opt/jasperreports-server-cp-5.5.0/installation.log" file

 

ogavavka's picture
162
Joined: Mar 12 2012 - 2:10pm
Last seen: 2 months 2 weeks ago
1

I don't have better details for you right now - but I know that PostgreSQL binary and it's initialization process utilizes symbolic links as part of the setup process. So, it looks as though there are not full permissions that are allowing the creation of the symbolic links. Or perhaps there is a different type of lock-down enforced on symbolic links within the AMI environment?

So, one thing to try as a workaround would be to get postgresql installed separately on the AMI instance. And then the JasperReports Server installer can install to that "existing" postgresql by choosing "custom install" on the first installer display screen. 

It is possible that the indivdual postgresql install can get the same problem - but at least that would narror the problem and allow a clearer discussion with AMI administrators - because of course an AMI needs to be able to install the postgresql database.  

 

 

tkavanagh's picture
3383
Joined: Jul 7 2006 - 8:54am
Last seen: 5 years 2 months ago
0

Thanks to you both for your help!

tkavanagh - I tried installing a standalone version of postgresql and connecting to that, which avoided some of the symbolic links, but then there were some others that came up for OpenSSL, which I don't think I can get around.

ogavavka - I tried your solution next, and spun up a new server and installed on there, which worked! I'd only spun up the previous one about an hour before trying the install, and had run yum updates, installed httpd and a MySQL server so I could then install WordPress too, but I don't see why any of that would have caused this behaviour.

I think I'll look at getting JasperReports Server running on the box solo, then try installing the others on one by one and see if they have any problems. Or I might just leave it on its own server.

Thanks again to you both!

nickmaher84's picture
Joined: Feb 18 2013 - 3:01pm
Last seen: 6 years 2 weeks ago
Feedback
randomness