Running iReport in ubuntu

0

Hi all,

I just installed iReport yesterday and it was working fine. But when I try to run it today it is not waroking properly.

Here is what I have done;

1. Downloaded iReport-4.0.2

2. extracted it in my downloads folder

3. try running though terminal 

          1.  udy@linux:~/Downloads/iReport-4.0.2/bin$ sudo ./ireport , this gives the No protocol specified error in terminal.

          2. udy@linux:~/Downloads/iReport-4.0.2/bin$ ./ireport (without sudo), this show many error messages in terminal and starts iReport. But again shows popup several errors. Still I cannot create or edit reports.

              here are the errors. I can post the output in terminal if needed. But its quite lengthy. 

 
I also tried moving the iReport-4.0.2 to the opt/ folder. Even that resulted the same thing.
Also my JasperServer is up and running. But when I run a report it returns the following error;
com.jaspersoft.jasperserver.api.JSException: java.lang.NoClassDefFoundError: Could not initialize class net.sf.jasperreports.engine.util.JRStyledTextParser
 
 do not know whether there is any connection between these two issues.
Please help.
uwarnasuriya's picture
Joined: Jan 31 2013 - 3:48am
Last seen: 5 years 3 months ago

2 Answers:

0

This looks to be a linux permissions/ownershipt issue.

Once an application is executed as root user (ie by using the "sudo" command) then any new file or possibly other files will end up with root ownership.

So, then, later if you try and run as a normal (non-root) user you will get permission errors (different message depending on application).

Probably the "best practice" thing to do would be to choose the user that you would like to have ireport and jasperreports-server as.

Then you would set all ownership to this user:

shutdown jasperreports-server

shutdown ireport

cd

chown myuser:mygroup -R *   (change everything in this folder to user: myuser and group: mygroup recursively)

cd

chown myuser:mygroup -R *

The only trick is that there will be/can be "temporary" files that still have the root ownership. These will still cause a problem.

You can delete these temporary/cache files:

/work/Catalina/localhost    (temp holding of compiled jsps etc)

/temp    (can delete contents)

And check if you find cached files in ubutu's folder /tmp

 

tkavanagh's picture
3163
Joined: Jul 7 2006 - 8:54am
Last seen: 5 years 3 weeks ago
0

cd /webapps/jasperserver

chown myuser:mygroup -R *

 

tkavanagh's picture
3163
Joined: Jul 7 2006 - 8:54am
Last seen: 5 years 3 weeks ago
Feedback
randomness