Does the latest Jasper Report Library (6.18.1) work on Tomcat 10.0?

0

I seem to be having difficulty getting Tomcat 10.0 to start properly to deploy a project that contains the Jasper Reports library (I upgraded to the 6.18.1 version). The error in the console is: 

java.lang.NoClassDefFoundError: net/sf/jasperreports/engine/JasperReport

 

hbruemmer's picture
Joined: Nov 24 2021 - 8:48am
Last seen: 1 week 2 days ago

1 Answer:

0

Each release has a "Supported Platforms" guide listing the versions that are certified. For Tomcat it lists 8.5.x, 9.0.x which are the versions that have gone through certification tests. 

vchiem's picture
23285
Joined: May 1 2017 - 5:33pm
Last seen: 1 day 18 hours ago
Feedback
randomness