Jasper Reports Server and JDBC of OpenSearch

0

Hi,

Is anybody using Jasper Reports Server with JDBC of Opensearch, https://github.com/opensearch-project/sql/tree/main/sql-jdbc?

With Jaspersoft Studio is working perfect (putting the JAR File of the JDBC driver in the Driver Classpath), but with Jasper Reports Server, uploading the same file with "Add Driver" using "Other" as JDBC, I obtain this error:

There was an error on the server. Try again or contact site administrators. (Error UID: eed507ea-53ce-4a3b-aba2-249d22697c35)

I tried to to add the JAR file of the JDBC driver to tomcat/lib and to tomcat/webapps/jasperserver/WEB-INF/lib and restart Tomcat Server with no luck too.

I tried Jasper Reports Server Bitnami Docker 7.8.1, and Jasper Reports Server Windows Installer 7.8.0.

Anyone using Jasper Reports Server and JDBC of OpenSearch?

Thanks in advance for your help.

aguida's picture
2
Joined: Nov 20 2021 - 6:47pm
Last seen: 1 week 6 days ago

1 Answer:

0

Not a common data source and it is not listed as certified but doesn't mean it won't work. The error has a UID that you can cross reference against the same UID in the jasperserver.log under WEB-INF\logs to see more info captured for this jdbc connectivity issue. 

 

 

vchiem's picture
23285
Joined: May 1 2017 - 5:33pm
Last seen: 1 day 18 hours ago
Feedback
randomness