Jump to content
Changes to the Jaspersoft community edition download ×

stasp

Members
  • Posts

    229
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

stasp's Achievements

Community Regular

Community Regular (8/14)

  • First Post Rare
  • Collaborator Rare
  • Conversation Starter Rare
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

2

Community Answers

  1. Jaspersoft® Product Suite will no longer include Simba Drivers after April 30, 2023. All Simba JDBC drivers, including the following, will be removed: - Athena - Cassandra - Impala - Neo4j - Spark FAQs What happens to my current installation that includes Simba Drivers after April 30, 2023? If you have a perpetual license to a Jaspersoft product version that includes Simba Drivers, you can continue using that particular version in your current installation. If you have a subscription license to Jaspersoft products that include Simba Drivers, you can continue using the Simba Drivers until the expiration of your current subscription term. However, for any subscription renewals occurring after April 30, 2023, you must upgrade your Jaspersoft products to versions without Simba Drivers as noted in the table below. Versions with Simba Drivers Included Versions without Simba Drivers Included JasperReports® Server 8.0.3 and earlier; 8.1.x 8.0.4 and later 8.0.x; 8.2.0 and later JasperReports® Server for AWS Marketplace 8.0.3 and earlier; 8.1.x 8.0.4 and later 8.0.x; 8.2.0 and later JasperReports® Server for Microsoft Azure 8.0.2 and earlier; 8.1.x 8.0.4 and later 8.0.x; 8.2.0 and later Jaspersoft® Studio 8.0.3 and earlier; 8.1.x 8.0.4 and later 8.0.x; 8.2.0 and later JasperReports® Library - Professional Edition 8.0.3 and earlier; 8.1.x 8.0.4 and later 8.0.x; 8.2.0 and later JasperReports® IO - Professional Edition 3.0.3 and earlier; 3.1.x 3.0.4 and later 3.0.x; 3.2.0 and later JasperReports® IO - At-Scale Edition 3.0.3 and earlier; 3.1.x 3.0.4 and later 3.0.x; 3.2.0 and later JasperReports® IO - Professional Edition for AWS Marketplace 1.2.0 and earlier 3.0.4 and later JasperReports® Web Studio - Professional Edition 1.0.0 2.0.0 and later Can I continue to receive assistance with JDBC drivers after April 30, 2023? Yes, the Jaspersoft Support team will continue to assist you with any JDBC driver issues used with Jaspersoft Product Suite, regardless of whether these drivers were obtained from us or a third party. However there will be no further Hotfixes or Service Packs for any potential issues with the listed Simba drivers. Will I be eligible to receive hotfixes and service packs for Jaspersoft product versions that include Simba drivers after April 30, 2023? For Mainstream (MS) releases, the answer is no. For the LTS releases 8.0.x and 3.0.x, the answer is yes. Such hotfixes and service packs will be delivered as version 8.0.4 (and later) and 3.0.4 (and later), where the Simba drivers are removed. What Jaspersoft product versions will be available on eDelivery after April 30, 2023? For Long-Term Support (LTS) releases, versions 8.0.4 (and later) and 3.0.4 (and later) will be available. For Mainstream (MS) releases, versions 8.2.0 and 3.2.0 will be available. Please reach out to the Jaspersoft Support team for assistance if you are entitled to an older version that is no longer available on eDelivery. What if I want to continue using Simba Drivers after upgrading to a version which doesn't include them? Where else can I get them? Please consult your legal team to make sure you are in compliance with vendor licensing before using/distributing any of the drivers listed below. You can contact insightsoftware to obtain licensing for Simba drivers. For native drivers, we can suggest contacting the vendors below: Amazon for Athena Cloudera for Impala Neo4j Datastax for Cassandra and Spark If you have any other questions please contact our Support via https://support.tibco.com/
  2. UPDATE: New cumulative patches are now available for JasperReports Server 8.0.3 and 8.1.1. For JRS 8.0.x: the latest 8.0.3 patch can be applied to any build of 8.0.0, 8.0.1, 8.0.2 or 8.0.3, including the Service Packs. It contains all fixes included in the latest 8.0.2 patch, and all the latest security fixes. For JRS 8.1.x: the latest 8.1.1 patch can be applied to any build of 8.1.0 or 8.1.1, including the Service Pack. It contains all fixes included in the latest 8.1.0 patch, and all the latest security fixes. All the hotfixes are available to download from TIBCO Support Portal. Following the directions below is no longer necessary. It is sufficient to apply the latest cumulative patch to your corresponding JasperReports Server version. For any questions, please contact TIBCO Support. PremiseOn December 13, 2022, Jaspersoft released a Service Pack with security fixes for the commercial releases of JasperReports Server 8.0.x and 8.1.x. The Service Pack is available for download from the TIBCO Support Portal, and more details about the addressed issues can be found on our Security Advisories page. IssueThe Service Pack is compatible with most builds of the corresponding versions 8.0.2 and 8.1.0 of JasperReports Server. If you don't see your JasperReports Server build number listed below, you can install the Service Pack following the standard steps from the README file. However, the Service Pack from December 13, 2022 is not compatible with several latest builds of cumulative hotfix for JRS versions 8.0.2 and 8.1.0. Please see the section below for the complete lists of the non-supported cumulative hotfix builds. Compatibility by VersionFor JasperReports Server 8.0.2the following cumulative hotfix builds are NOT compatible with the Service Pack 8.0.3:hotfix_JRSPro8.0.2_cumulative_20221007_0310.ziphotfix_JRSPro8.0.2_cumulative_20221021_1338.ziphotfix_JRSPro8.0.2_cumulative_20221031_1613.ziphotfix_JRSPro8.0.2_cumulative_20221102_0944.ziphotfix_JRSPro8.0.2_cumulative_20221108_1535.ziphotfix_JRSPro8.0.2_cumulative_20221114_0154.ziphotfix_JRSPro8.0.2_cumulative_20221206_1040.ziphotfix_JRSPro8.0.2_cumulative_20221208_0915.zipFor JasperReports Server 8.1.0the following cumulative hotfix builds are NOT compatible with the Service Pack 8.1.1:hotfix_JRSPro8.1.0_cumulative_20220930_0923.ziphotfix_JRSPro8.1.0_cumulative_20221024_0418.zipIf you have a JasperReports Server build incompatible with the Service Pack 8.0.3 or 8.1.0 If you are currently using a JasperReports Server build that is listed in the section above, it means that one of the newest versions of JRS hotfixes was applied to your JRS instance. In that case, at the moment the best approach for applying the Service Pack is as follows: Re-install JasperReports Server of your corresponding version (8.0.2 or 8.1.1) from the original (vanilla) distribution. NOTE: The underlying Repository Database for the JRS instance may remain untouched. Only the deployment in the application server (usually in the WAR file format) needs to be re-deployedApply the Service Pack for your corresponding version (8.0.3 or 8.1.1) to the new JRS deploymentAlternatively, you can wait for the changes from the aforementioned builds to be backported to cumulative hotfixes for versions 8.0.3 and 8.1.1. These cumulative hotfixes will be released as soon as they pass all the necessary test. How to check your JasperReports Server build numberOn any page of JasperReports Server user interface, click on the 'About' link in the bottom left corner of any page of the application. A small pop-up window will appear which shows the build version of your deployment: For any questions, please contact TIBCO Support
  3. UPDATE: New cumulative patches are now available for JasperReports Server 7.5.2, 7.8.1 and 7.9.1. For JRS 7.5.x: the latest 7.5.2 patch can be applied to any build of 7.5.1, and also to 7.5.2 Service Pack. It contains all fixes included in the latest 7.5.1 patch, and all the latest security fixes. For JRS 7.8.x: the latest 7.8.1 patch can be applied to any build of 7.8.0, and also to 7.8.1 Service Pack. It contains all fixes included in the latest 7.8.0 patch, and all the latest security fixes. For JRS 7.9.x: the latest 7.9.1 patch can be applied to any build of 7.9.0, and also to 7.9.1 Service Pack. It contains all fixes included in the latest 7.9.0 patch, and all the latest security fixes. All the hotfixes are available to download from TIBCO Support Portal. Following the directions below is no longer necessary. It is sufficient to apply the latest cumulative patch to your corresponding JasperReports Server version. For any questions, please contact TIBCO Support. PremiseOn October 12, 2021, TIBCO Jaspersoft released a Service Pack with security fixes for all the currently supported commercial versions of JasperReports Server. The Service Pack is available for download from the TIBCO Support Portal, and more details about the addressed issues can be found on our Security Advisories page. IssueThe released Service Pack is compatible with the Generally Available (the base) build of JasperReports Server for each corresponding version, as well as with the majority of the cumulative hotfix build for each corresponding version. However, the Service Pack from October 12, 2021 is not compatible with several latest builds of cumulative hotfix for JRS versions 7.5.1, 7.8.0 and 7.9.0. Please see the section below for the complete lists of the supported cumulative hotfix builds. Compatibility by VersionFor JasperReports Server 7.9.0the following cumulative hotfix builds are compatible with Service Pack 7.9.1:Initial JasperReports Server 7.9.0 release, build 20201202_2053hotfix_JRSPro7.9.0_cumulative_20210126_1045.ziphotfix_JRSPro7.9.0_cumulative_20210205_0933.ziphotfix_JRSPro7.9.0_cumulative_20210305_0557.ziphotfix_JRSPro7.9.0_cumulative_20210401_1704.ziphotfix_JRSPro7.9.0_cumulative_20210427_1201.ziphotfix_JRSPro7.9.0_cumulative_20210506_0744.ziphotfix_JRSPro7.9.0_cumulative_20210511_0714.ziphotfix_JRSPro7.9.0_cumulative_20210517_0750.ziphotfix_JRSPro7.9.0_cumulative_20210524_0222.ziphotfix_JRSPro7.9.0_cumulative_20210608_0150.zipAll fixes available for JRS 7.9.0 which are not included in the builds listed above will be released later, as part of a cumulative patch for version 7.9.1. For JasperReports Server 7.8.0the following cumulative hotfix builds are compatible with Service Pack 7.8.1:Initial JasperReports Server 7.8.0 release, build 20200807_1438hotfix_JRSPro7.8.0_cumulative_20200903_1722.ziphotfix_JRSPro7.8.0_cumulative_20201012_1447.ziphotfix_JRSPro7.8.0_cumulative_20201021_1501.ziphotfix_JRSPro7.8.0_cumulative_20201023_1424.ziphotfix_JRSPro7.8.0_cumulative_20201109_0718.ziphotfix_JRSPro7.8.0_cumulative_20201112_1255.ziphotfix_JRSPro7.8.0_cumulative_20201119_1044.ziphotfix_JRSPro7.8.0_cumulative_20201209_1512.ziphotfix_JRSPro7.8.0_cumulative_20201224_0543.ziphotfix_JRSPro7.8.0_cumulative_20210118_1419.ziphotfix_JRSPro7.8.0_cumulative_20210121_1634.ziphotfix_JRSPro7.8.0_cumulative_20210127_1609.ziphotfix_JRSPro7.8.0_cumulative_20210203_1155.ziphotfix_JRSPro7.8.0_cumulative_20210209_1430.ziphotfix_JRSPro7.8.0_cumulative_20210216_0228.ziphotfix_JRSPro7.8.0_cumulative_20210226_0129.ziphotfix_JRSPro7.8.0_cumulative_20210303_1326.ziphotfix_JRSPro7.8.0_cumulative_20210406_1035.ziphotfix_JRSPro7.8.0_cumulative_20210423_0954.ziphotfix_JRSPro7.8.0_cumulative_20210519_0959.ziphotfix_JRSPro7.8.0_cumulative_20210525_0250.ziphotfix_JRSPro7.8.0_cumulative_20210531_0818.ziphotfix_JRSPro7.8.0_cumulative_20210607_1302.zipAll fixes available for JRS 7.8.0 which are not included in the builds listed above will be released later, as part of a cumulative patch for version 7.8.1. For JasperReports Server 7.5.1the following cumulative hotfix builds are compatible with Service Pack 7.5.2:Initial JasperReports Server 7.5.1 release, build 20200507_1627 hotfix_JRSPro7.5.1_cumulative_20200601_1100.ziphotfix_JRSPro7.5.1_cumulative_20200624_0657.ziphotfix_JRSPro7.5.1_cumulative_20200710_2031.ziphotfix_JRSPro7.5.1_cumulative_20200716_1950.ziphotfix_JRSPro7.5.1_cumulative_20200720_1831.ziphotfix_JRSPro7.5.1_cumulative_20200730_1215.ziphotfix_JRSPro7.5.1_cumulative_20200916_1323.ziphotfix_JRSPro7.5.1_cumulative_20201005_1714.ziphotfix_JRSPro7.5.1_cumulative_20201009_1022.ziphotfix_JRSPro7.5.1_cumulative_20201012_1219.ziphotfix_JRSPro7.5.1_cumulative_20201015_1426.ziphotfix_JRSPro7.5.1_cumulative_20201020_1718.ziphotfix_JRSPro7.5.1_cumulative_20201027_0834.ziphotfix_JRSPro7.5.1_cumulative_20201028_0528.ziphotfix_JRSPro7.5.1_cumulative_20201105_1514.ziphotfix_JRSPro7.5.1_cumulative_20201128_1310.ziphotfix_JRSPro7.5.1_cumulative_20210118_2309.ziphotfix_JRSPro7.5.1_cumulative_20210122_1659.ziphotfix_JRSPro7.5.1_cumulative_20210209_1128.ziphotfix_JRSPro7.5.1_cumulative_20210219_1510.ziphotfix_JRSPro7.5.1_cumulative_20210322_0449.ziphotfix_JRSPro7.5.1_cumulative_20210413_0301.ziphotfix_JRSPro7.5.1_cumulative_20210607_1354.zipIf you have a JasperReports Server build incompatible with the Service Pack 7.5.2, 7.8.1 or 7.9.1 If you are currently using a JasperReports Server build that is not listed in the section above, it means that one of the newest versions of JRS hotfixes was applied to this instance. In that case, at the moment the best approach for applying the Service Pack is as follows: Re-install JasperReports Server of your corresponding version (7.9.0, 7.8.0 or 7.5.1) from the original (vanilla) installer. NOTE: The underlying Repository Database for the JRS instance may remain untouched. Only the deployment in the application server (usually in the WAR file format) needs to be re-deployedApply the Service Pack for your corresponding version (7.9.1, 7.8.1 or 7.5.2) to the new JRS deploymentHow to check your JasperReports Server build numberIn a default (non-customized) JasperReports Server user interface, click on the 'About' link in the bottom left corner of any page of the application. A small pop-up window will appear which shows the build version of your deployment: For any questions, please contact TIBCO Support
  4. Issue descriptionStarting Sunday, January 17 2021 all jobs in Jaspersoft ETL/Talend Studio, as well as in Talend Administrative Center (TAC) fail to run or compile. The exact stack trace of the exception will vary based on the operation you are trying to perform, but the root cause will look similar to this: java.security.cert.CertificateExpiredException: NotAfter: Sun Jan 17[/code]CauseThe exceptions are caused by an unprecendted issue with Talend product stack where a set of certificates have expired (on January 17, 2021). Please see this article for more details: https://community.talend.com/s/article/REQUIRED-by-Jan-17-2021-Mandatory-Talend-Certificate-update-for-Talend-v7-0-v7-1-v7-2-v7-3 SolutionYou will have to apply patch to the affected products (Jaspersoft ETL/Talend Studio and/or Talend Administrative Center) in order address the problem. For JETL/Talend Studio:- Download patch distribution Patch_20201211_TPS-4416_v2-7.1.1.zip - Follow the instructions from the Readme Notes: https://help.talend.com/r/G2Umu1essoGJRFm7SFxzbA/5XCYs91bTTsh6kHXA2ttcw For Talend Administrative Center (TAC):- Download patch distribution Patch_20201211_TPS-4556_v2-7.1.1.zip (or the newer version, Patch_20210115_TPS-4632_v1-7.1.1.zip) - Follow the instructions from the Readme Notes: https://help.talend.com/r/xAG5ieGhYWbhI84Y~cCdpQ/U51sEUUUCfpxQuZma0zIxw If you are running a Job Server- See if you need to follow the Additional Instructions: https://community.talend.com/s/article/REQUIRED-by-Jan-17-2021-Mandatory-Talend-Certificate-update-for-Talend-v7-0-v7-1-v7-2-v7-3-Additional-Instructions - Restart your Job Server For TAC 7.3.1 with jobs that were migrated from version 7.1.1- you may experience the same exception, in which case you and need to download and apply the patch for TAC version 7.3.1_ Patch_20201215_TPS-4576_v1 (for TAC): Link: https://talend365-my.sharepoint.com/:u:/g/personal/dsegard_talend_com/ESC1Ojk622pHvDo36FvOiucBt-D3XQ0S9CbNdLaxQVXh8w?e=MuS8sE Password: eh&PEshrMJeu:6=T Additional troubleshootingIf you have applied the patch and some of the jobs are still failing with an exception like this: Failed to execute goal org.talend.ci:signer-maven-plugin:7.1.1:sign (sign) on project Test_job: Sign artifact failed: NotAfter: Sun Jan 17 05:36:12 IST 2021 -> [Help 1][/code]you will have to replace the signer-maven-plugin-7.1.1 jar. Please follow these steps: - Backup file the jar file in the directory below <studio_installation_folder>/configuration/.m2/repository/org/talend/ci/signer-maven-plugin/signer-maven-plugin-7.1.1.jar - Replace the signer-maven-plugin-7.1.1 jar in the directory with the attached jar. - Restart the application
  5. This video provides guidelines for adding custom functions to Ad Hoc Designer in Jasperreports Server 7.2.x or 7.5.x.
  6. This video goes over the functionality of the new textAdjust attribute, which was introduced in JasperReports Library 7.5.0 to replace the deprecated isStretchWithOverflow. === In JasperReports Library 7.5.0 the isStretchWithOverflow attribute has been deprecated, and replaced with the textAdjust attribute. These are helpful when your textField's dimensions might be too small for the amount of data which might come from your datasource. The textAdjust attribute includes the original two behaviors and adds a third. - CutText: involves is the default behavior and like the previous default behavior it involves truncation. - StretchHeight: replicates the previous behavior you got from setting isStretchWithOverflow to true - ScaleFont: is new, The font size of the text is scaled down so that the entire content fits the text field element size. Reference: http://jasperreports.sourceforge.net/schema.reference.html#textField ===
  7. This video goes over the background and required steps to configure which day of the week should be listed first in Calendar Date Picker on JasperReports Server 7.5.x. For a similar video for JasperReports Server 7.2.x and earlier please check out this link: https://community.jaspersoft.com/wiki/video-how-configure-first-day-date-picker-tibco-jasperreports-server-72x
  8. This video goes over the background and required steps to configure which day of the week should be listed first in Calendar Date Picker on JasperReports Server 7.2.x. For a similar video for JasperReports® Server 7.5.x please check this link: https://community.jaspersoft.com/wiki/video-how-configure-first-day-date-picker-tibco-jasperreports-server-75x
  9. This video focuses on creating a new Google Cloud database and importing existing database structure from a *.sql file. For more detailed overview of creating a Google Cloud database from scratch, as well as for creating a Data Source connection to such database from JasperReports Server, please check the previous video from the series:
  10. This video demonstrates how to configure VisualVM for Tomcat and then generate a Heap dump or a Thread dump.
  11. This video gives a brief introduction to Ad Hoc Crosstabs in general, and then focuses on a specific use case of configuring custom Date/Time format for Crosstab date grouping.
  12. This video provides an overview of various hyperlink types available for HTML5 charts, and demonstrates how to create simple Reference type hyperlink for a sample chart.
  13. The video demonstrates how to use the system routines in Jaspersoft ETL, and also how to design the routines of your own. The code sample of the customer Base64 encoding routine mentioned in the video is attached.
  14. This video demonstrates how to load two Java heap dumps into a VisualVM tool and compare the recorded performance. The heap dumps can be collected from different JasperReports Server environments and/or at different times, and VisualVM lets you compare the resource consumption between the two.
  15. This video provides a step-by-step demonstration of setting up and working with a remote GitHub repository in Jaspersoft ETL Studio and Talend Adminitration Center.
×
×
  • Create New...