Jump to content
JasperReports Library 7.0 is now available ×


  • Posts

  • Joined

  • Last visited

Cilisca's Achievements


Newbie (1/14)

  • Week One Done
  • One Month Later
  • One Year In
  • First Post Rare
  • Conversation Starter Rare

Recent Badges



  1. Hello, I'm currently developing a excel report with certain report elements. My problem is, that I'll try to export the report into EXCEL-Format and the column are not displayed correctly. In the header, there are some text fields to display the report description and more informations. After those textfields, I need to display a crosstab. The column of the text fields and one column of the crosstab are the same. The column is automatically stretched to the size of the text field, which I try to prevent. I wanted to adjust the column width to a specific crosstab cell, instead of the text field width. The data of the textfield should overlap to the next cell. But there should not be a cell merge. I set the following properties for the textfield: <property name="net.sf.jasperreports.export.xls.auto.fit.row" value="false"/><property name="net.sf.jasperreports.export.xls.auto.fit.column" value="false"/>[/code]And the following properties to the crosstab cell: <property name="net.sf.jasperreports.export.xls.auto.fit.row" value="true"/><property name="net.sf.jasperreports.export.xls.auto.fit.column" value="true"/>[/code]I there any way to auto adjust a cell size to a specific field or crosstab cell? I’m thankful for every little tip :) Regards, Vanessa
  2. I'm having the same error with my crosstab and parameter configuration.I'm using iRepot Designer 4.7.1....... Maybe there is someone who knows the answer in 2015
  3. A little bit late, but i have a possible answer for you and all others that are facing this problem. You can use the built-in funtoin "str". So the solution for you would be something like this: str($V{resourceBundleName}) The $R{} funktion is not working in this case. Hope it helps
  • Create New...