Jump to content
We've recently updated our Privacy Statement, available here ×

rajeevt

Members
  • Posts

    10
  • Joined

  • Last visited

rajeevt's Achievements

Apprentice

Apprentice (3/14)

  • Week One Done
  • One Month Later
  • One Year In
  • First Post Rare
  • Collaborator Rare

Recent Badges

0

Reputation

  1. I have a group by column field which seems to print correctly in pdf but is blank when I look at in html on FireFox. What causes the field not to display? Is it overflow? Although I say print correctly in pdf, it seems to have extra space underneath which I do not know where it appears from but the vlaue shown is correct. Generally, how can I establish the reason for a field not showing properly? Regards Rajeev
  2. At what stage are the group variables calculated? I have a calculated variable in my group with evaluation time of 'auto'. I want to conditionally print the group band if variable has a certain value. When I run the report without conditional printing it shows correct value in my variable but when I use it in my conditional 'print when expression' for the band it has a value of 0. This is also true for auto generated fields like grp_COUNT which displays correctly but seems to have a value of zero in calculation. Why? How? Feeling frustrated and lost. Please help. Regards Rajeev
  3. In number of posts I see reference to samples/demo. Where can I find these for ireport? The standard download had no samples. Regards Rajeev
  4. I am trying to show a calculated field as a percentage. I have given the field type of BigDecimal and created an expression to display as one decimal percent. My expression is: ($F{available}- $F{booked})/($F{available} - $F{sup_booked}) It works correctly when $F(available) and $F{booked} are not same. When they are it gives 0 and it seems that the report requires 0.0 so I created the following expression: ($F{available}- $F{booked}) == 0? 0.0 : ($F{available}- $F{booked})/($F{available} - $F{sup_booked}) This one works fine but fails when both $F(available) and $F{booked} are zero. Surely there must be a straightforward way of doing this calculation. Can somebody point out what I am doing wrong? Regards Rajeev
  5. Whenever I try to Build/Execute a report from within ireport, it doesn't execute if it has an error. However, it doesn't show me what the error is. It is very frustrating to try and establish what has gone wrong. Is there some option which needs to be set which shows the error if build/execute fails? Is the error stored in some log file? Help! Regards Rajeev Post edited by: rajeevt, at: 2007/03/07 15:09
  6. Thanks jmurray. It worked! Strangely enough I had read this as a possible solution in a previous posting in the forum but couldn't get it to work yesterday. Obviously the new day has brought a more relaxed perspective and clarity. Thanks again. Rajeev
  7. Thanks jmurray. It worked! Strangely enough I had read this as a possible solution in a previous posting in the forum but couldn't get it to work yesterday. Obviously the new day has brought a more relaxed perspective and clarity. Thanks again. Rajeev
  8. I have a SQL statement with five fields and I want to be able to sort it dynamically by setting the sort order as a parameter. The first field is a group by field so I have written something like select v1, v2, v3, v4, v5 from tab order by $P{p1} I set the value of p1 parameter to something like " 1, 3" or " 1,4". It seems to ignore sort order altogether. However if I hardcode order by clause to be 'order by 1,3' it works. What is going on? Can we not set the sort order dynamically? I have tried other variants for 'order by' clause but cannot get it work. Help! Reagrds Rajeev
  9. I have managed to solve it. I had to pass ../reports in my SUBREPORTS_DIR path to make it work. Any absolute path gave problem. Regards Rajeev
  10. I am trying to deploy a jasperreport with a subreport in Tomcat environment. The normal reports without subreport work perfectly. However, the master report has a SUBREPORT_DIR parameter from where it should pickup the subreport.jasper. What is the value I should be passing to this parameter? I have tried various options but always get an exception saying couldn't load the object from the directory. The syntax I use is as below: private static final String PREFIX = "/WEB-INF/reports/"; private static final String SUFFIX = ".jasper"; externalContext econtext = getExternalContext(); InputStream stream = econtext.getResourceAsStream(PREFIX + name + SUFFIX); JasperPrint jasperPrint = null; jasperPrint = JasperFillManager.fillReport(stream, params, conn); Regards Rajeev
×
×
  • Create New...