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  • How to Fix the Blank Homepage Contents Issue After the Upgrade


    Dhiraj Pahlani
    • Features: User Interface Version: v7, v7.9, v7.9.0, v7.8, v7.5, v7.5.1, v7.5.0, v7.3, v7.2.2, v7.2.1, v7.2.0, v7.1 Product: Jasper Deployment

    Problem:

    You've upgraded your TIBCO JasperReports® Server (which uses SSL and a proxy server URL) and after the upgrade when accessing the homepage of the JasperReports Server, the homepage contents (like, Ad Hoc Views, Reports, Dashboards, Domains, etc.) are not visible and the homepage seen is blank.


    Cause:

    This may happen because the JasperReports Server is not configured to use only SSL and/or the configurations for using the proxies are not made correctly for the current version of JasperReports® Server.


    Solution:

    1. Try to configure your JasperReports Server to use proxy:

      1. Open the js.config.properties (jasperserver-pro/WEB-INF)file in an editor.
      2. Search for the deploy.base.url property and provide your proxy server URL as the value to this property, like: deploy.base.url=https://bi.example.com/jasperserver-pro
      3. Similarly, search for the report.scheduler.web.deployment.uri property under this same file and provide your proxy server URL as the value to this property, like: report.scheduler.web.deployment.uri=https://bi.example.com/jasperserver-pro
      4. Save the file.
      5. Restart the application server for the changes to reflect.

      For more details on the configurations for using proxies, refer the below documentation link:

      https://community.jaspersoft.com/documentation/tibco-jasperreports-server-administrator-guide/v750/configuration-using-proxies

      For JasperReports Server v7.9.0, you may refer the below documentation link to know about the configurations for using proxies:

      https://community.jaspersoft.com/documentation/tibco-jasperreports-server-administrator-guide/v790/configuration-using-proxies

      After performing the above actions, you may try to access the JasperReports Server homepage again to check if the issue is now resolved and you're able to see the homepage contents again after the upgrade.

    2. If you're still facing the issue with blank homepage contents, and are using Tomcat as the application server with SSL, the next suggestion, in addition to the above would be to configure your JasperReports Server to use only SSL.

      To know how to configure your JasperReports Server to use only SSL, refer the below documentation link:

      https://community.jaspersoft.com/documentation/tibco-jasperreports-server-security-guide/v7/enabling-ssl-tomcat

    3. If you're still facing the blank home page contents issue even after performing all of the above actions, then please review your applicationContext-rest-services.xml (<jasperserver-pro>/WEB-INF) file and see if you've defined the roles under required beans to either enable or disable the access to homepage items to the specified roles. For more details on this, refer the below Wiki article and watch the short video to know how to enable or disable homepage items based on roles:

      https://community.jaspersoft.com/wiki/video-enabling-or-disabling-homepage-items-based-roles

    Performing the above actions should help resolve the blank homepage contents issue. If you continue to experience the same issue even after performing all of the above suggestions, consider opening a case with the Support as the issue then can be environment specific as well.


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