Jump to content
Changes to the Jaspersoft community edition download ×

NullPointerException


Recommended Posts

By: Rama Kodumagulla - rkodumagulla

NullPointerException

2003-01-02 08:24

I have this problem when using WSAD 5.0, but the same code runs fine using command line compile.

 

java.lang.NullPointerException

at org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1094)

at org.apache.commons.digester.Digester.parse(Digester.java:1144)

at dori.jasper.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:353)

at dori.jasper.engine.xml.JRXmlLoader.load(JRXmlLoader.java:309)

at dori.jasper.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:96)

at org.dhhs.dirm.acts.query.QueryApp.main(QueryApp.java:146)

 

NESTED BY :

dori.jasper.engine.JRException

at dori.jasper.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:357)

at dori.jasper.engine.xml.JRXmlLoader.load(JRXmlLoader.java:309)

at dori.jasper.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:96)

at org.dhhs.dirm.acts.query.QueryApp.main(QueryApp.java:146)

 

 

Here is my code:

fileName = "C:\Install\ActsReports\templates\QueryOneDef.xml";

 

System.setProperty("jasper.reports.compile.class.path", "C:\install\ActsReports\Jasperreports\lib\jasperreports.jar");

 

System.setProperty("jasper.reports.compile.temp", "C:\install\ActsReports\templates");

 

String oldSaxDriver = System.setProperty("org.xml.sax.driver", "org.apache.xerces.parsers.SAXParser");

 

JasperCompileManager.compileReportToFile(fileName);

System.err.println("Compile time : " + (System.currentTimeMillis() - start));

System.exit(0);

 

I am failing to compile the XML document.

 

Your help will be highly appreciated.

 

Thanks,

 

rkodumagulla

 

 

 

 

By: Teodor Danciu - teodord

RE: NullPointerException

2003-01-02 10:26

 

Hi,

 

It seems that the "filename" variable gets to be null

when passed to the report compiling process.

 

Double check this, or send me your JSP/servlet.

 

Thank you,

Teodor

 

 

 

 

 

By: Vani - itsme123

RE: NullPointerException

2003-01-16 18:19

I am getting same problem when I run the report on Tomcat 4 using servlets.

The same works on command line build script.

 

Thanks.

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...