Jump to content
Changes to the Jaspersoft community edition download ×

Static Parameters in subReport


2005 IR Help

Recommended Posts

By: Larcheveque - mcheit

Static Parameters in subReport

2004-11-10 02:52

 

Hello, I am drawing a master report enclosing some subreports. When I define some default values in my subReports parameters those one remain static even when I modify the parameters HashMap values that I pass to the JasperRunManager object in my application, and when I don't set any default value my subReports don't appear in my master report... The master report enclose some paramters as well but without default value, and it works in the dynamic way, I fell that just the subReports can't access to the parameters HasMap...

 

Any suggestion would be welcomed!

--

Benjamin

 

PS: my code is a bit long but I can join it under request.

 

 

 

 

By: Larcheveque - mcheit

RE: Static Parameters in subReport

2004-11-10 07:00

 

I solved my problem: actually I am using iReport to generate my subReport and i forget to map the parameters from the master report to the subReport...

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...