Jump to content
Changes to the Jaspersoft community edition download ×

Report blank when used as subreport


Recommended Posts

By: crrowland - crrowland

Report blank when used as subreport

2006-05-23 12:34

I have created a report that gets populated with data when I run it on its own.

 

When I try to use the same report as a subreport, the report is blank.

 

Am I missing something obvious?

 

 

 

 

By: crrowland - crrowland

RE: Report blank when used as subreport

2006-05-24 06:43

I kind of solved my own problem.

 

My report had no data (no query) so the detail section had nothing to show, and my subreports therefore were skipped.

 

My solution was to have my report query to just return 1 record..

 

select count(id) from blah;

 

It seems to work ok, is this a good way to do it?

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...