Jump to content
Changes to the Jaspersoft community edition download ×

jdt-compiler fails inside applet using jdk1.5

Recommended Posts

By: Michael Tuschik - tuschik

jdt-compiler fails inside applet using jdk1.5

2006-04-27 09:43



i have a problem using JasperReports inside an applet. Running the application standalone Jasper is doing fine. Running with appletviewer all is ok. Running in browser (IE) using JDK 1.4 all works good. But if i use JDK 1.5 (1.5.0_06) Jasper fails to compile the reports with the jdt-compiler:


net.sf.jasperreports.engine.JRException: Errors were encountered when compiling report expressions class file:

1. The type java.lang.Object cannot be resolved. It is indirectly referenced from required .class files



1 errors


at net.sf.jasperreports.engine.design.JRAbstractCompiler.compileReport(JRAbstractCompiler.java:164)

at net.sf.jasperreports.engine.design.JRDefaultCompiler.compileReport(JRDefaultCompiler.java:131)

at net.sf.jasperreports.engine.JasperCompileManager.compileReport(JasperCompileManager.java:211)


versions i use:

Java: 1.5.0_06

Jasper: 1.1.0 (tried 1.2.2 too)

JDT-Compiler: tried both from Jasper 1.1.0 and 1.2.2


pls help! i have no ideas anymore :(

Thanks Michael






By: Michael Tuschik - tuschik

RE: jdt-compiler fails inside applet using jd

2006-04-28 08:29


Hey, i found the bug and reported it with ID 1478460 :





Link to comment
Share on other sites

  • 4 months later...
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

I get this error, too - I use JasperReports 1.3.0 and JDK 1.5_06. Unfortunately I was not able to find any solution so far (searched jasperreports-questions, jasperforge and the web), but may be my queries were not precise enough.


The bug report mentioned above is not available to the public. Is the bug still open?


Can anyone point me to a solution or give me hints where to start looking? What am I doing wrong?





Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...