Jump to content
Changes to the Jaspersoft community edition download ×

Running an report hitting oracle


aramachandra

Recommended Posts

Can someone please educate me on where to define the jdbc driver.

I have updated the context.xml and web.xml file to have my datasources and the url is tested fine in the ireport tool.

I have tried locally defined and repository based oracle data source and still get the java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver.

Let me know where else do i need to configure the jdbc driver.

org.springframework.webflow.ActionExecutionException:    Exception thrown executing [AnnotatedAction@1c82208 targetAction = com.jaspersoft.jasperserver.war.action.ViewReportAction@324b85,                                attributes = map[[empty]]] in state 'verifyData' of flow 'viewReportFlow';    nested exception is com.jaspersoft.jasperserver.api.JSExceptionWrapper:        java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver com.jaspersoft.jasperserver.api.JSExceptionWrapper:            java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver[/code]
Link to comment
Share on other sites

  • 3 weeks later...
  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

You need to place your oracle driver within the lib directory of the web app. Example.

jasperintelligence-1.0apache-tomcatwebappsjasperserverWEB-INFlib

 

From there the app server will automatically pick it up and load the driver.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...