Jump to content
Changes to the Jaspersoft community edition download ×

using JasperReports with JDK1.3.1


2005 IR Help

Recommended Posts

By: Pablo del Vecchio - pablodv

using JasperReports with JDK1.3.1

2004-05-10 08:11

We've got a problem trying to use JasperReports with JDK1.3.1 The thing is that we followed the instructions on not using org.xml.sax, and using instead the solution of org.apache.xerces.parsers.SAXParser.

 

After generating a JasperPrint, we showed the report using JasperViewer. Viewing only a blank pdf page.

 

This exactly process works 'OK' for JDK1.4.2

 

We also compiled and created jasperreports.jar using ant, to solve the problem with for the javax.print libraries.

 

Thank you in advance for the help.

 

 

 

Pablo del Vecchio

 

 

 

 

 

 

By: Chuck Deal - cdeal

RE: using JasperReports with JDK1.3.1

2004-05-11 05:53

Since, JDK 1.4.x comes with an xml parser, perhaps you were not truly using the xerces parser.

 

I was able to use JasperReports with JDK 1.2.2, 1.3.x, and 1.4.x. I would reinvestigate the system property: -Dorg.xml.sax.driver=org.apache.xerces.parsers.SAXParser to make sure that you are using it properly.

 

 

 

 

By: Teodor Danciu - teodord

RE: using JasperReports with JDK1.3.1

2004-05-13 13:53

 

Hi,

 

Are you generating the reports on one machine and

view them on another, using a different JVM?

 

Cand you export the report to XML format and see

what it contains?

 

Thank you,

Teodor

 

 

 

 

 

By: Pablo del Vecchio - pablodv

RE: using JasperReports with JDK1.3.1

2004-05-14 02:53

Yes, we were generating the xml with iReport 0.2.3 (JDK1.4.2_04)

and our application uses JDK1.3.1_01. we have solved the problem looking at other

post also in this forum

 

http://sourceforge.net/forum/forum.php?thread_id=1068703&forum_id=113530

 

and also looking at

 

http://cvs.sourceforge.net/viewcvs.py/itext/www/tutorial/ch09.html?rev=1.27

 

The thing is that the font code encoding for Europe is "Cp1252", and not "CP1252".

This has to do also with iText and how iReport generates the xml.

For the JDK 1.4.2 this works with either way, but for JDK 1.3.1 the "Cp1252" is

the correct. So changing that directly in the worked OK.

 

Teodor, the thing is now that we cannot use JaperViewer with JDK 1.3.1. We have

to show the pdf using the web navigator instead.

 

Thanks for the reponse Chuck Deal and Teodor Danciu.

 

Greetings,

 

 

 

Pablo del Vecchio

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...