Jump to content
Changes to the Jaspersoft community edition download ×

java.time.LocalDate cannot be found by net.sf.jasperreports_6.20.6.final


Recommended Posts

Recently I suddenly encounter such error "java.time.LocalDate cannot be found by net.sf.jasperreports_6.20.6.final" in the report that worked several years. I've just tried to Read Fields in Dataset and Query Dialog.
I am using  java.time.LocalDate as Parameter type where do some date calculations based on other parameters. The report still works fine. Other reports with java.time.LocalDate used in expressions that return String - allow Read Fields without issues.
When now go to parameter type drop down - there is no java.time.LocalDate in the list, but it was there for years.
So looks like some degradation in JasperSoft Studio 6.20.6 (run under Ubuntu 22.04) or even earlier.
Is there some workaround for this until it will be fixed? 

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...