Jump to content
Changes to the Jaspersoft community edition download ×

Issues after changing from Postgres to MSSQL


nyasaki

Recommended Posts

Hi,

i'm trying to install the jasperreports server pro version 7.9.0 on fedora.
We are currently running it on a windows server and want to migrate to linux.

I installed the server via the install tool, after copying the config files from out currently running server,
I get a few SQL exceptions and I dont know what to do anymore.

I've tried fixing it on my own, withour much success.

2023-04-13T06:45:04,610 ERROR SqlExceptionHelper,localhost-startStop-1:131 - [TibcoSoftware]
[sqlServer JDBC Driver][sqlServer]An expression of non-boolean type specified in a context where a condition is expected, near 'ilike'. 2023-04-13T06:45:04,685 ERROR SqlExceptionHelper,localhost-startStop-1:131 - [TibcoSoftware][sqlServer JDBC Driver][sqlServer]Statement(s) could not be prepared. 2023-04-13T06:45:05,045 ERROR ContextLoader,localhost-startStop-1:313 - Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'proOnStartPropagator' defined in ServletContext resource [/WEB-INF/applicationContext-onStart-web-pro.xml]: Invocation of init method failed; nested exception is org.springframework.orm.hibernate5.HibernateJdbcException: JDBC exception on Hibernate data access: SQLException for SQL [n/a]; SQL state [HY000]; error code [4145]; could not extract ResultSet; nested exception is org.hibernate.exception.GenericJDBCException: could not extract ResultSet [/code]

Full error messages included as attachment

 

I would be very thankful for any hints on how to fix this, im on this for a while already.

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Installation worked fine with the installer, and it did run after installing.
But then I tried switching from Postgres to MSSQL and things started breaking apart

~/jasperreports-server-7.9.0/apache-tomcat/webapps/jasperserver-pro/WEB-INF/logs/jasperserver.log is the log file

The errors occur when starting the service / server

Link to comment
Share on other sites

Did you re-install the repository database or just the server?

The "ilike" statement is postgres and would not work well with MySQL.  This would happen if somehow the server thinks it is using postgres still.

To move from Postgres to MySQL, I would recommend exporting the repository, do a clean from-scratch build using MySQL, and importing the repository.

Since you are using a commercial product, have you reached out to Jaspersoft Production Support on this?

Link to comment
Share on other sites

I cant find the link anymore, I remember changing a context file in the tomcat folder.
And since we got the software via a 3rd party, we are not able to get commercial support.

Is there any guide I can follow for the clean build?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...