Jump to content
Changes to the Jaspersoft community edition download ×

Records with # symbol missing from my CSV report


basven

Recommended Posts

I programatically call the fillReport method and use the CSVExporter to export data:

JasperPrint jp = JasperFillManager.fillReport(jasperReport, parameters, connection);JRCsvExporter csvExporter = new JRCsvExporter();SimpleCsvExporterConfiguration configuration = new SimpleCsvExporterConfiguration();configuration.setFieldDelimiter(delimiter);csvExporter.setConfiguration(configuration);csvExporter.setExporterInput(new SimpleExporterInput(jp));csvExporter.setExporterOutput(new SimpleWriterExporterOutput(file));csvExporter.exportReport();

  I noticed however that rows with the # sign are not part of my CSV report; is there some option I need to specify to tell Jasper to handle certain characters ?

Thanks for any info,

Bas

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

It is almost like the csv exporter sees the # character as the start of a comment and then omits everything after that. And I mean all data, not just the current row.

When I export using the JRTextExporter or the JRXlsxExporter, I see all expected data, including the data that has this character in it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...