Jump to content
Changes to the Jaspersoft community edition download ×

Password in JIJdbcDatasource doesn't update


gaurav.maini
Go to solution Solved by gaurav.maini,

Recommended Posts

Hi, I have installed Jasper Reports Server 7.1.0 on Mac 10.14.1 with Tomcat 9.0 and MySQL 5.6.8

I installed using the WAR option and used an existing tomcat server and an existing MySQL server. When I try to create a new datasource to my MySQL server, I use the MySQL JDBC driver.

After entering the username and password, when I click "Test Connection", I get a success message. But when I save it and reopen it to edit and then click "Test Connection", I get a message - "Connection failed".

On checking the table JIJdbcDatasource, I see that the password column never updates for the connection I am creating. Any password I enter in the datasource results in the same hash in the password column.

I have tried installing Jasper reports server with the bundled postgres SQL and tomcat, but get the same results.

Anyone run into the same thing?

Anyone know what HASH is used for the password column? I am also ok setting the password manually un my MySQL database.

Thanks!

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Ok, I figured out the problem here. My password had a special character "@" and this was being encoded into "safe" HTML and this breaks the code. Once I the exception occurs in saving the form, the code stays in a broken state and does not accept any other passwords.

Proposed fix: Remove the special character from the password. Note: any special character that encodes to HTML with a < or > sign breaks the code.

Would love to see the code fixed in an update.

Link to comment
Share on other sites

  • Solution

Ok, I figured out the problem here. My password had a special character "@" and this was being encoded into "safe" HTML and this breaks the code. Once I the exception occurs in saving the form, the code stays in a broken state and does not accept any other passwords.

Proposed fix: Remove the special character from the password. Note: any special character that encodes to HTML with a < or > sign breaks the code.

Would love to see the code fixed in an update.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...