Jump to content
Changes to the Jaspersoft community edition download ×

internationalization unicode is not displayed on pdf


yinfeng6118

Recommended Posts

Hello everyone,

I am developing internationalization,

I defined a few properties files such as i18n_ja_JP.properties.

the file content is unicode as following,

test=u308Fu304Bu308B

when I executed "Preview" on Jaspersoft Studio 6.5.0 final, It could be shown "わかる",

But when I do this via jasperReports6.5.1 on Eclipse as following, nothing is shown.

ResourceBundle resourceBundle = ResourceBundle.getBundle("i18n_ja_JP");

parameters.put(JRParameter.REPORT_RESOURCE_BUNDLE, resourceBundle);

JasperRunManager.runReportToPdfFile("Blank_A4.jasper", parameters, new JREmptyDataSource());

If change unicode to ISO-8859-1, it can't be shown correctly, such as [ããã].

I tried to export html file ,it worked normally ,but pdf.

who can help me ?

Michael

 

 

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...