Jump to content
Changes to the Jaspersoft community edition download ×

Repository file could not be loaded


ajax.picard

Recommended Posts

Repository file resource /reportes/Totales_files/Bonif.jrxml could not be loaded/

---

com.jaspersoft.jasperserver.api.JSShowOnlyErrorMessage: Repository file resource /reportes/Totales_files/Bonif.jrxml could not be loaded Arguments: at com.jaspersoft.jasperserver.war.action.ViewReportAction.executeReport(ViewReportAction.java:678) at etc

---

I tried in several servers, linux and windows.

Works fine INSIDE JPStudio

in this expression, i tried all the combinations

<subreportExpression><![CDATA["repo:Bonif.jasper"]]></subreportExpression>

ej: with/without 'repo'

tried : "Bonif.jasper" and "Bonif.jrxml" 

only "Bonif" too

The subreport Bonif works ok in all servers.

this property is set <connectionExpression><![CDATA[$P{REPORT_CONNECTION}]]></connectionExpression>

 

I deleted de subreport from de main report, added a new one, select 'from the jasper server' in the JRStudio dialog,  navigate to the resource main_jrxml (the selectable ones)

(Sometimes, subreport doesnt display, has to restar JRStudio and reapeared)

and having this

Repository file resource /organizations/organization_1/reportes/Bonif_files/main_jrxml

ANY HELP!!

TIP, other subreports, with images  in folder 'images' worsk fine individually

----

UPDATE

I tried the following with other reports

1)Created the report and subreport

2)uploaded 'only' the main report to server

 2.1 it works, but subreport doesn' appears in server (cannot reuse?)

3) deleted  report form server

4) uploaded subreport FIRST, then, main report

4.1 same error as subject (subreport works fine)

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...