Jump to content
Changes to the Jaspersoft community edition download ×

Backcolor don't apply to text?


2005 IR Help

Recommended Posts

By: David Lim - aberrant80

Backcolor don't apply to text?

2004-03-07 03:12

Calling setBackcolor for static text elements don't seem to work. The background is still the default white. My mistake? If not, any workaround?

 

I think it's much easier to use the back color attribute of a text element than to put a text element and a rectangle inside an element group....

 

David.

 

 

 

 

 

By: Teodor Danciu - teodord

RE: Backcolor don't apply to text?

2004-03-07 03:57

 

Hi,

 

Make your text fields opaque.

The default is mode="Transparent".

Check the "Quick Reference" for details.

 

I hope this helps.

Teodor

 

 

 

 

 

By: David Lim - aberrant80

RE: Backcolor don't apply to text?

2004-03-07 04:05

Yep, that helped, thanks. but uh... teodor... i think you missed mentioning the default value for mode. So since Opaque came first, I thought default was opaque ;)

 

 

 

 

By: Teodor Danciu - teodord

RE: Backcolor don't apply to text?

2004-03-07 04:22

 

Hi,

 

I've missed it because it depends on the type of the

element.

Graphic elements are "Opaque" by default, but text

elements are "Transparent" by default.

 

Thank you,

Teodor

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...