Jump to content
Changes to the Jaspersoft community edition download ×

PDF problem in AIX


2004 IR Help

Recommended Posts

By: david chan - davidchantf

PDF problem in AIX

2005-10-11 11:19

Hi,

 

I have the PDF report looks fine in windows, but after deploy to AIX, (using java.awt.headless=true, JDK 1.4) the PDF looks different, i.e. some words disappear in between pages, (I have one field with long text can go to a few pages).

 

The PDF font I am using is Helvetica, I tried PDF embedded=true, still doesn't work.

 

I am using jasper report 1.0.2, websphere application server 6.0.1, in AIX

 

Any suggestion?

 

Thanks.

David

 

 

 

 

By: rstewart - rstewartmailacc

RE: PDF problem in AIX

2005-10-11 11:50

Hi David,

 

I hope you have better luck with this than I have. I have been working with IBM for more than a month on this.

 

I am running WAS 6.01 on Iseries with all of the latest fixes and JasperReports 1.02. My .pdf has a variable length field that displays 2 inches of extra unwanted blank space before my sub-report on Iseries. This works great on WebSphere Development Studio Client 6.01 and corresonding test server for Windows just not on Iseries.

 

IBM has tested it on their AIX and Iseries servers and suggested that JasperReports look into it. The response is below between the $ signs.

 

I am very frustrated with this as I have also tried the suggestions given on this forum without success.

 

Good luck.

Randall

 

IBM tech support response:

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

Development has reviewed the testcase you have sent me and have made these

findings:

 

1. AIX JVM shows the same results as the iSeries JVM

2. It looks like this is a "wrap handling" situation, since the default

terms text (retrieved from the callILE()) in the report is too wide for the

page. The fact that the intermediate form wraps the text, but handles the

overflow differently based on platform, points to an issue in the Jasper

code with margin handling and estimation.

 

Although we haven't figured EXACTLY what the difference is, it probably has

to do with the difference in line end/carriage return characters used

between a Windows model and a UNIX/iSeries model. The JasperReports code

appears to have been written in a way that varies its results based on this

different line end model.

 

Our suggestion is to try and work around the difference using one of these

suggestions:

 

1. "Narrow" the text retrieved from the callILE() by reflowing it about 10

characters narrower, or

2. Remove all newlines except the double-newline at the end of each

'paragraph.'

 

 

If not, then we suggest going to JasperReports to find out the difference

between Windows and UNIX/iSeries models.

$$$$$$$$$$$$$$$$$$$$$$$$$$$

Link to comment
Share on other sites

  • 5 years later...
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...