Jump to content
Changes to the Jaspersoft community edition download ×

Problems with PDF Font Embedded


Recommended Posts


First of all, I tried every tutorial and example that I found on the internet also in this community.

My problem is, I created a report in my local station (Linux: Deepin), and my JSF application is running in a server (Linux: Ubuntu). So In my local station the report is perfect, but when I commit and send to the server and print the same report it cut some words.

I tried to generate Font Extensions, tried to change the font directly, tried to change Workspace and Project Settings setting the PDF Font Name and Font Default, also tried to create Font Extension and create a Style to apply to the PDF and it doesn't work.

The only tutorial that I can't do until the end was generate a Font Extension export as a .jar and add do the Build Path of my Jasper Project, because the Build Path returns an error "NullPointerException" inside the JasperStudio, I tried in other laptop installing a brand new JasperStudio and the Build Path show the same error.

I noticed that the PDF Font Name is always Helvetica no matter what I change.

So could you guys have any solution, because I don't know what to do more.

Thanks in advance.

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...