Jump to content
Changes to the Jaspersoft community edition download ×

JasperReport with Webshpere ????


2004 IR Help

Recommended Posts

By: wimaya - wimaya

JasperReport with Webshpere ????

2004-12-02 01:55

I made some report using jasperReport, when I run using tomcat, it was success, but when I tried to run using Websphere Application server 5.0.2.7 in AS400 I got some error.

 

My error is :

 

SRVE0026E: [servlet Error]-[AWT class or API used without specifying property os400.class.path.rawt=1 or os400.class.path.rawt=2]: java.awt.AWTError: AWT class or API used without specifying property os400.class.path.rawt=1 or os400.class.path.rawt=2 java/lang/Throwable.<init>(Ljava/lang/String;)V+4 (Throwable.java:85) java/lang/Error.<init>(Ljava/lang/String;)V+1 (Error.java:41) java/awt/AWTError.<init>(Ljava/lang/String;)V+1 (AWTError.java:28) com/ibm/as400/system/NoGraphicsEnvironment.<init>()V+31 (NoGraphicsEnvironment.java:48) java/lang/Class.newInstance()Ljava/lang/Object;+14 (Class.java:238) java/awt/GraphicsEnvironment.getLocalGraphicsEnvironment()Ljava/awt/GraphicsEnvironment;+27 (GraphicsEnvironment.java:53) net/sf/jasperreports/engine/util/JRGraphEnvInitializer.initializeGraphEnv()V+0 (JRGraphEnvInitializer.java:98) net/sf/jasperreports/engine/fill/JRBaseFiller.<init>(Lnet/sf/jasperreports/engine/JasperReport;Lnet/sf/jasperreports/engine/fill/JRBaseFiller;)V+0 (JRBaseFiller.java:212) net/sf/jasperreports/engine/fill/JRVerticalFiller.<init>(L -- <truncated> --

 

Is JasperReport not compatible with websphere ??? or am I did something wrong with the code ??, I think the problem related with AWT class. What I suppose to do :( ??? Help me please.......

 

Best Regards

Wimaya Septiningrum

 

 

 

 

 

By: srinivas - srini_maduri

NoClassDefFoundError In Unix Machine

2005-09-11 23:17

Hi all

 

Iam using the following code to generate the jasper reports in

Excel format.. I developed them using JDeveloper on windows machine

which is working fine. When Iam trying to deploy the same on Unix

machine, it is throwing the following Exception.

 

java.lang.NoClassDefFoundError: net/sf/jasperreports/engine/fill/JRVerticalFiller

 

not even there is no nested exception.

 

 

System.setProperty(

"jasper.reports.compile.class.path",

context.getRealPath("/WEB-INF/lib/jasperreports-0.6.1.jar")

+ System.getProperty("path.separator"));

+ context.getRealPath("/WEB-INF/classes/"));

File reportFile =

new File(

getServletContext().getRealPath(

"/myreport/" + fileName + ".jasper"));

JasperReport jasperReport =

(JasperReport) JRLoader.loadObject(reportFile.getPath());

 

 

Pls suggest me a good solution

 

regards

srinivas.M

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...