Jump to content

Jaspersoft 5.6.1 report using domains fails to run on server


francois.schneider

Recommended Posts

Hello,

 

When developping reports with Jaspersoft Studio using Domains, this work well, even with sub reports using domains.

 

When publishing the report and their sub reports on the Jaspersoft server, then the report fails to run.

 

The error message is:

net.sf.jasperreports.engine.JRRuntimeException: net.sf.jasperreports.engine.JRException: java.lang.RuntimeException: exception initting subfilters

 

I looked for a solution on the Web and I found that I need to pass the following parameter map expression: $P{REPORT_PARAMETERS_MAP}

This is what I did for all sub-report calls but didn't solve anything.

 

When I remove the subreports, the report works on the server. When I add the sub reports I get the error.

 

I did several tests and don't have any issue when using SQL requests on sub reports, this fails with domains only.

 

 

 

HERE AFTER IS THE CODE CALLING THE SUB REPORT FROM THE MAIN REPORT:

 

 

  <band height="20">

   <subreport>

    <reportElement x="-10" y="0" width="200" height="20" uuid="e21ed202-1022-4fe3-a129-2dbec1b5871d"/>

    <parametersMapExpression><![CDATA[$P{REPORT_PARAMETERS_MAP}]]></parametersMapExpression>

    <subreportParameter name="projectKey_1">

     <subreportParameterExpression><![CDATA[$P{projectKey_1}]]></subreportParameterExpression>

    </subreportParameter>

    <connectionExpression><![CDATA[$P{REPORT_CONNECTION}]]></connectionExpression>

    <subreportExpression><![CDATA["repo:TA_Request Validation by the TA manager.jrxml"]]></subreportExpression>

   </subreport>

  </band>

 

 

 

HERE AFTER IS THE START OF THE SUB REPORT DEFINITION:

 

 

<?xml version="1.0" encoding="UTF-8"?>

<!-- Created with Jaspersoft Studio version 5.6.1.final using JasperReports Library version 5.6.1  -->

<!-- 2016-02-11T16:18:11 -->

<jasperReport xmlns="http://jasperreports.sourceforge.net/jasperreports" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://jasperreports.sourceforge.net/jasperreports http://jasperreports.sourceforge.net/xsd/jasperreport.xsd" name="TA_Request Validation by the TA manager" pageWidth="595" pageHeight="842" columnWidth="555" leftMargin="20" rightMargin="20" topMargin="20" bottomMargin="20" uuid="41ba5d24-6fbe-4439-886c-acfa689c0068">

 <property name="ireport.jasperserver.url" value="https://cppmrpt201s.ondemand.ca.com/reportservice/"/>

 <property name="ireport.domainUri" value="/shared/BostikDomains/Bostik___TA04_–_Technical_Assistance_Q03"/>

 <property name="com.jaspersoft.studio.data.defaultdataadapter" value="Domain JRS"/>

 <property name="ireport.jasperserver.report.resource" value="/shared/BostikReports/Test_TA_files/TA_Request Validation by the TA manager.jrxml"/>

 <property name="ireport.jasperserver.reportUnit" value="/shared/BostikReports/Test_TA"/>

 <parameter name="LoggedInUser" class="com.jaspersoft.jasperserver.api.metadata.user.domain.User" isForPrompting="false"/>

 <parameter name="LoggedInUsername" class="java.lang.String" isForPrompting="false"/>

 <parameter name="projectKey_1" class="java.math.BigDecimal">

  <defaultValueExpression><![CDATA[new java.math.BigDecimal("0")]]></defaultValueExpression>

 </parameter>

 <queryString language="domain">

  <![CDATA[<query>

 <queryFields>

  <queryField id="Query03.X_VAL_CMT"/>

  <queryField id="Query03.X_TSK_REQUEST_STATUS"/>

  <queryField id="Query03.X_TSK_DATETAV2"/>

  <queryField id="Query03.X_PRKJ_EXPECTEDAN"/>

  <queryField id="Query03.X_PRJ_EXP_HOURS"/>

  <queryField id="Query03.INV_ID"/>

  <queryField id="Query03.FULL_NAME"/>

 </queryFields>

 <queryFilterString>Query03.INV_ID == projectKey_1</queryFilterString>

</query>]]>

 </queryString>

 

 

 

Please do you know what is the problem there ?

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...