Jump to content
Changes to the Jaspersoft community edition download ×

keepjava not working in JasperReports 1.0


2004 IR Help

Recommended Posts

By: John Zoetebier - johnzoet

keepjava not working in JasperReports 1.0

2005-07-26 21:47

I run ant taks in demo/samples/antcompile like this:

ant compile1

 

The reports are generated, but no intermediate java files for these reports.

Then I changed the Ant task to put the temporary java files in:

<target name="compile1">

<mkdir dir="./build/reports"/>

<jrc

srcdir="./reports"

destdir="./build/reports"

tempdir="./temp"

keepjava="true"

xmlvalidation="true">

<classpath refid="classpath"/>

</jrc>

</target>

 

Still no java files.

Next I compiled the reports from a java program. Same result : no java files.

 

I have previous version JasperReports 0.5.1 which is working fine.

 

My platform is:

JasperReports 1.0

Mandrive LE 2005

 

What can be wrong here ?

 

 

 

 

 

By: Teodor Danciu - teodord

RE: keepjava not working in JasperReports 1.0

2005-07-27 04:49

 

Hi,

 

A few months ago we have added the JDT-based report

compiler which besides being faster than the JDK-based

ones, it also does not require temporary files on disk to

work with.

This is why there were no files "to keep" on disk.

However, when inspecting the compiles yesterday I saw

this issue and decided it should be fixed.

So if you grab the latest version from CVS, the java

file will be generated and kept if the flag is set to true.

 

This will be part of the next release.

 

Thank you,

Teodor

 

 

 

 

 

By: John Zoetebier - johnzoet

RE: keepjava not working in JasperReports 1.0

2005-07-28 00:03

Yes, CVS version does work properly for keepjava argument.

Thanks for fixing it :)

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...